Last Comment Bug 762880 - Missing MOZALLOC_EXPORT causes link failure on mingw
: Missing MOZALLOC_EXPORT causes link failure on mingw
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: mozglue (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: mozilla16
Assigned To: Jacek Caban
:
Mentors:
Depends on:
Blocks: 761859
  Show dependency treegraph
 
Reported: 2012-06-08 06:17 PDT by Jacek Caban
Modified: 2012-06-12 03:40 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1.0 (869 bytes, patch)
2012-06-08 06:17 PDT, Jacek Caban
ted: review+
Details | Diff | Review

Description Jacek Caban 2012-06-08 06:17:29 PDT
Created attachment 631366 [details] [diff] [review]
fix v1.0

It looks like bug 761859 accidentally removed MOZALLOC_EXPORT define, causing mozalloc_abort to not be marked as exported.

Successful try run:
https://tbpl.mozilla.org/?tree=Try&rev=e15ebf4408ca
Comment 1 Ted Mielczarek [:ted.mielczarek] 2012-06-08 07:35:03 PDT
Comment on attachment 631366 [details] [diff] [review]
fix v1.0

Review of attachment 631366 [details] [diff] [review]:
-----------------------------------------------------------------

Oops, sorry.
Comment 2 Jacek Caban 2012-06-11 00:54:09 PDT
Thanks for the review.

https://hg.mozilla.org/integration/mozilla-inbound/rev/93214bac07b2
Comment 3 Jacek Caban 2012-06-12 03:40:46 PDT
I accidentally referenced blocked bug instead of this one in the commit. Landed on m-c as:

https://hg.mozilla.org/mozilla-central/rev/93214bac07b2

Note You need to log in before you can comment on or make changes to this bug.