Last Comment Bug 762887 - IonMonkey: Add infallible MUnbox after known-object type barrier
: IonMonkey: Add infallible MUnbox after known-object type barrier
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Jan de Mooij [:jandem] (PTO until July 31)
:
Mentors:
Depends on:
Blocks: IonSpeed
  Show dependency treegraph
 
Reported: 2012-06-08 06:45 PDT by Jan de Mooij [:jandem] (PTO until July 31)
Modified: 2012-06-09 02:10 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.69 KB, patch)
2012-06-08 06:45 PDT, Jan de Mooij [:jandem] (PTO until July 31)
dvander: review+
Details | Diff | Splinter Review

Description Jan de Mooij [:jandem] (PTO until July 31) 2012-06-08 06:45:59 PDT
Created attachment 631370 [details] [diff] [review]
Patch

If a type barrier has type "object" (but not "any object") we have to use MTypeBarrier instead of MUnbox because we have to test the object types. This patch adds an infallible unbox after the type barrier to avoid a bunch of fallible unbox instructions inside a hot loop on SS-fannkuch.
Comment 1 Jan de Mooij [:jandem] (PTO until July 31) 2012-06-09 02:10:06 PDT
http://hg.mozilla.org/projects/ionmonkey/rev/7f354603e953

Note You need to log in before you can comment on or make changes to this bug.