Automatic upgrade to 12.0 on uncompatible MacOSX 10.4.11 renders Firefox unusable

RESOLVED DUPLICATE of bug 762472

Status

()

Toolkit
Application Update
RESOLVED DUPLICATE of bug 762472
6 years ago
6 years ago

People

(Reporter: Eduardo Trápani, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Newer versions of Firefox cannot run on an old MacOSX 10.4.11.  But the automatic upgraded downloaded and installed the new version anyway.

So I got a "You cannot use the application Firefox.app with this version of MacOSX".

The only solution I found was to go fishing for an older version here[1].  After trying 11.0, and 10.0.2 and 9.0 I found out that 3.6.28 is the last one supported worked.

The upgrade should check if the platform is supported before upgrading.

[1] https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/
Component: General → Application Update
Product: Firefox → Toolkit
QA Contact: general → application.update
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 762472
You need to log in before you can comment on or make changes to this bug.