Last Comment Bug 762934 - IA2_EVENT_TEXT_SELECTION_CHANGED event produces incorrect results when several text objects are selected
: IA2_EVENT_TEXT_SELECTION_CHANGED event produces incorrect results when severa...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: 13 Branch
: x86_64 Windows 7
-- normal (vote)
: mozilla27
Assigned To: alexander :surkov
:
: alexander :surkov
Mentors:
Depends on:
Blocks: caretsela11y
  Show dependency treegraph
 
Reported: 2012-06-08 08:30 PDT by Jost Eckhardt, Ai Squared
Modified: 2013-10-26 18:30 PDT (History)
3 users (show)
surkov.alexander: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description User image Jost Eckhardt, Ai Squared 2012-06-08 08:30:00 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0
Build ID: 20120531155942

Steps to reproduce:

select several text objects


Actual results:

The problem is that Firefox reports that only one(first) text object is selected while we have several selected objects on the screen. I`m not sure if we can reproduce it with the AccProbe.


Expected results:

Multiple selected objects should be reported
Comment 1 User image alexander :surkov 2012-06-08 08:39:30 PDT
(In reply to Jost Eckhardt, Ai Squared from comment #0)
> Steps to reproduce:
> 
> select several text objects

do you mean single selection like
<p>text |<a>anchor</a><img>|</p> 
or multiple selections through the document like
|<p>this is selected paragraph</p>|
<p> this is not selected</p>
|<p> this one is selected again</p>|
where | | denotes start and end of the selection
Comment 2 User image Jost Eckhardt, Ai Squared 2012-06-11 05:57:14 PDT
Single selection of multiple objects

|<p>selected paragraph 1</p>
<p>selected paragraph 2</p>
<p>selected paragraph 3</p>| 

IA2 will return only selected paragraph 1
Comment 3 User image alexander :surkov 2012-06-11 06:17:09 PDT
what accessible do you get the selection from?
Comment 4 User image Alex Kulikov, Ai Squared 2012-06-11 07:46:14 PDT
Alexander,

we process IA2_EVENT_TEXT_SELECTION_CHANGED events in the following way:
1)Use AccessibleObjectFromEvent function to get an accessible object associated with the event (on the WinEventProc side);
2)Query accessible object for IAccessibleText interface (through IAccessible2 interface);
3)Get selection information using IAccessibleText::nSelections and IAccessibleText::selection.
Comment 5 User image alexander :surkov 2012-06-11 07:51:19 PDT
Got it, thanks.
Comment 6 User image alexander :surkov 2013-10-26 18:28:36 PDT
ашчув ин игп 928504

Note You need to log in before you can comment on or make changes to this bug.