Last Comment Bug 762948 - [adbe 3212446] Repainting issue of Flash content when scrolling with Flash Player 11.3.300.257
: [adbe 3212446] Repainting issue of Flash content when scrolling with Flash Pl...
Status: RESOLVED FIXED
[flash-11.3]
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86 Windows 7
: -- normal with 8 votes (vote)
: mozilla17
Assigned To: Bas Schouten (:bas.schouten)
: Ioana (away)
: Milan Sreckovic [:milan]
Mentors:
: 588789 635065 766859 769957 773544 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-08 09:16 PDT by Alice0775 White
Modified: 2013-02-12 06:12 PST (History)
39 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
+
verified
+
verified
+
verified


Attachments
screenshot (598.69 KB, image/png)
2012-06-08 09:16 PDT, Alice0775 White
no flags Details
screenshot (425.75 KB, image/png)
2012-06-08 13:29 PDT, Alice0775 White
no flags Details
Repainting issue on Youtube (718.42 KB, application/octet-stream)
2012-06-09 00:17 PDT, kolubinowicki
no flags Details
screenshot (116.57 KB, image/jpeg)
2012-06-12 08:12 PDT, Vlad [QA]
no flags Details
Problem with Flash Version: 11.3.300.262. (577.96 KB, image/png)
2012-06-21 03:32 PDT, Alice0775 White
no flags Details
Screenshot, DxDiag and about:support (154.84 KB, application/octet-stream)
2012-06-24 03:53 PDT, MrX1980
no flags Details
scrollable flash page (1.32 KB, text/html)
2012-06-29 07:55 PDT, Jim Mathies [:jimm]
no flags Details
Workaround for an invalidation problem with flash (1.91 KB, patch)
2012-07-22 21:26 PDT, Bas Schouten (:bas.schouten)
no flags Details | Diff | Splinter Review
Workaround for an invalidation problem with flash v2 (3.22 KB, patch)
2012-07-22 23:26 PDT, Bas Schouten (:bas.schouten)
roc: review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Alice0775 White 2012-06-08 09:16:53 PDT
Created attachment 631428 [details]
screenshot

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/6338a8988917
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1 ID:20120606030528

This is not a recent regression.(I can see the issue in Firefox 9.0.1 at least)

Reproducible: Always (easily reproduced)

Steps to Reproduce:
1. Open http://underworld2ch.blog29.fc2.com/?no=1840 
2. Scroll page by dragging a thumb of vertical scroll bar
3. Repeat Step 2

Actual Results:
 Flash content repainting fails

Expected Results:
 No fail
Comment 1 Alice0775 White 2012-06-08 09:35:34 PDT
This happens with Flash Player 11.3.300.257.
However, This does not happen with Flash Player 11.2.202.235.
Comment 2 smadayag 2012-06-08 12:37:57 PDT
i'm not able to reproduce.  it's possible it graphics card related.  which GPU do you have and which driver version?  also, check the manufacturer's website to see if there are any updates for your particular card.  thanks...
Comment 3 Alice0775 White 2012-06-08 12:56:18 PDT
*This happens with/without HWA(Firefox and Flash),
*This happens with/without OOPP.

*Used latest Graphic driver.

Graphics       
Adapter Description: ATI Radeon HD 4300/4500 Series
Vendor ID: 0x1002
Device ID: 0x954f
Adapter RAM: 512
Adapter Drivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Driver Version: 8.961.0.0
Driver Date: 4-5-2012
Direct2D Enabled: true
DirectWrite Enabled: true (6.1.7601.17789)
ClearType Parameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 50 Enhanced Contrast: 50 
WebGL Renderer: Google Inc. -- ANGLE (ATI Radeon HD 4300/4500 Series) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)
GPU Accelerated Windows: 1/1 Direct3D 10
 AzureBackend: direct2d
Comment 4 Alice0775 White 2012-06-08 13:29:48 PDT
Created attachment 631516 [details]
screenshot

This also happens on Youtube by resize window
http://www.youtube.com/watch?feature=endscreen&v=4drucg1A6Xk&NR=1
Comment 5 Alice0775 White 2012-06-08 13:55:17 PDT
Screen capture:
http://youtu.be/whzoqrHPVmk
Comment 6 timbugzilla 2012-06-08 22:03:12 PDT
Scrolling during youtube video playback causes a lot of flash video frames to be dropped for me.
Comment 7 kolubinowicki 2012-06-09 00:17:52 PDT
Created attachment 631622 [details]
Repainting issue on Youtube

I can easily reproduce the bug on Youtube with latest Nightly, please check attachment for more info.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1
Adapter Description NVIDIA Quadro FX 570M
Vendor ID0x10de
Device ID0x040c
Adapter RAM256
Adapter Drivers
nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2umDriver Version8.17.12.9670
Driver Date4-27-2012
Direct2D Enabled true
DirectWrite Enabled
true (6.1.7601.17789)
ClearType ParametersClearType parameters not found
WebGL RendererGoogle Inc. -- ANGLE (NVIDIA Quadro FX 570M) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)
GPU Accelerated Windows1/1 
Direct3D 10
AzureBackenddirect2d
Comment 8 Alex Keybl [:akeybl] 2012-06-10 17:28:53 PDT
I don't believe an in-product change will be needed for this since it's directly related to the release of Flash Player 11.3.300.257 and reproduces with older versions of Firefox. Given that, no reason to track for Firefox's next release. This still appears to be a significant Flash issue, however.
Comment 9 Vlad [QA] 2012-06-12 08:12:58 PDT
Created attachment 632260 [details]
screenshot

I can confirm this behavior on:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0 beta 6 (1st beta)

As you can see from the attachment, the issue is reproducing using Flash 11.3.300.250 and also my video card is a Nvidia GeForce 210 driver version 296.10.

I didn't noticed this behavior on Win 7 x86 with exactly the same configuration.
Comment 10 Alice0775 White 2012-06-12 08:17:55 PDT
(In reply to Vlad [QA] from comment #9)
> Created attachment 632260 [details]
> screenshot
This is not a bug. The screen shot is correct result.
Comment 11 Jeromie Clark 2012-06-12 19:10:11 PDT
I'm unable to reproduce the underworld issue on Firefox 14b6 with Flash Player 11.3.300.257 on a Lenovo W500.  Flash Player 11.3 does widen GPU acceleration support to more older cards.

Disabling Hardware Acceleration through Flash Player Settings Manager is a quick and easy check to eliminate GPU as a root-cause.

There's a full troubleshooting guide here: 
http://helpx.adobe.com/flash-player/kb/video-playback-issues.html

If these issues persist, we're more than happy to investigate.  There's a much larger array of GPU and driver combinations in the field than we can hope to test, although we do our best to put a dent in that text matrix.

The best way to get a resolution for a particular display card is to file a bug against flash player at http://bugbase.adobe.com.  Including a URL to reproduce the issue and the output of dxdiag would be particularly helpful.

I've filed a bug on our end (3212149) to ensure that someone follows up on the information reported in this thread.  Any additional feedback, especially on results of the troubleshooting guide referenced above would be appreciated.
Comment 12 Kurt Pruenner 2012-06-19 08:54:03 PDT
(In reply to Jeromie Clark from comment #11)
> I've filed a bug on our end (3212149) to ensure that someone follows up on
> the information reported in this thread.  Any additional feedback,
> especially on results of the troubleshooting guide referenced above would be
> appreciated.

Even after several different searches in your bugbase I can't find an entry with that ID, and the dain bramaged decision to forego links for some lookalike onclick handlers that prevent one from opening results in new tabs certainly doesn't help.

Has that "bug on your end" been deleted?
Comment 13 (mostly gone) XtC4UaLL [:xtc4uall] 2012-06-19 10:24:31 PDT
(In reply to Jeromie Clark from comment #11)
> The best way to get a resolution for a particular display card is to file a
> bug against flash player at http://bugbase.adobe.com.

Is http://bugs.adobe.com/jira/browse/FP abandoned?

(In reply to Kurt Pruenner from comment #12)
> Even after several different searches in your bugbase I can't find an entry
> with that ID

Confirmed. https://bugbase.adobe.com/index.cfm?event=bug&id=3212149 leads to "The information requested is not found"
Comment 14 Jeromie Clark 2012-06-19 10:27:29 PDT
I filed the bug directly with the engineering team.  It's open and being worked on.

Also, I did paste the wrong bug number.  The internal bug ID is 3212446.

I'm more than happy to clone the internal engineering bug to a public bug if you'd like.  We would update that bug once the bug is closed on our end; however, it won't effect a fix any faster.
Comment 15 Alice0775 White 2012-06-21 03:32:25 PDT
Created attachment 635241 [details]
Problem with Flash  Version: 11.3.300.262.

I can still reproduce  with Flash    Version: 11.3.300.262.
http://hg.mozilla.org/mozilla-central/rev/c3190d715044
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1 ID:20120620065138
Shockwave Flash    Version: 11.3.300.262
Comment 16 MrX1980 2012-06-24 03:53:41 PDT
Created attachment 636146 [details]
Screenshot, DxDiag and about:support

http://www.musikmarkt.de/Aktuell/News/EM-2012-Die-EM-Songs-im-Ueberblick-mit-Videos

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0a1
buildID = 20120623030532

FlashPlayer 11.3.300.262
Nvidia GT240 with 304.48 driver
Comment 17 Loic 2012-06-26 01:38:57 PDT
*** Bug 766859 has been marked as a duplicate of this bug. ***
Comment 18 Tam Nguyen 2012-06-26 01:56:42 PDT
I've rolled back to 11.2.202.235 and the repainting issue is gone.

Here are my specs:
EVGA X58 E758-A1 132-BL-E758-A1
Intel Core i7-960 Bloomfield 3.2GHz (Oc'ed at 3.6GHz)
OCZ ModXStream Pro OCZ700MXSP 700W ATX12V V2.2 / EPS12V
OCZ Platinum 3x2GB DDR3-1600 (PC3 12800) OCZ3P1600LV6GK
BFG Tech BFGEGTX275896OCE GTX 275 896MB 448-bit
Antec Sonata Elite Black
Intel SSD 160 GB SSDSA2M160G2GC
WD VelociRaptor 150GB 10000rpm 16MB Cache (x1)
WD 640GB 7200rpm 16MB Cache (x2)
Hitachi 500GB 7200rpm 16MB Cache (x1)
Razer Salmosa Gaming Mouse
Windows 7 Ultimate x64
Comment 19 Jim Mathies [:jimm] 2012-06-29 07:54:26 PDT
I see this quite often now. Attaching a test case. The repainting problem also bleeds into content, it's not just in the plugin window.
Comment 20 Jim Mathies [:jimm] 2012-06-29 07:55:01 PDT
Created attachment 637908 [details]
scrollable flash page
Comment 21 MrX1980 2012-06-29 11:00:48 PDT
The same with Flash Player prerelease 11.4.400.195
Comment 22 Loic 2012-06-30 16:47:33 PDT
*** Bug 769957 has been marked as a duplicate of this bug. ***
Comment 23 Dan Q (RedBlade7) 2012-06-30 16:52:36 PDT
Loic, I posted a new comment to 769957 exactly 22 seconds before you marked it a dupe.

Want me to repaste it here? It has quite a bit of useful info.
Comment 24 kolubinowicki 2012-07-01 07:15:54 PDT
Duplicate of this  bug: Bug 588789 - Scrolling Content up and down in Firefox will cause flash-based video to look weird 

https://bugzilla.mozilla.org/show_bug.cgi?id=588789
Comment 25 Jim Mathies [:jimm] 2012-07-01 07:58:22 PDT
*** Bug 588789 has been marked as a duplicate of this bug. ***
Comment 26 Dan Q (RedBlade7) 2012-07-01 12:16:15 PDT
This same problem is also happening with Java applets (using Java plugin v6u33)

Examples:
http://java.sun.com/applets/jdk/1.4/demo/applets/ImageMap/example1.html
http://www.gokgs.com/tutorial/chains.js

NOTE: See also my crash report @ https://crash-stats.mozilla.com/report/index/bp-a1e2b78e-0319-442b-a9b9-573412120701
Comment 27 Dan Q (RedBlade7) 2012-07-01 12:17:05 PDT
http://www.gokgs.com/tutorial/chains.jsp

(not .JS)
Comment 28 Dan Q (RedBlade7) 2012-07-01 12:30:02 PDT
Also happening with Java plugin v7u5
Comment 29 Benjamin Smedberg [:bsmedberg] 2012-07-02 07:47:46 PDT
Dan Q, this bug is specifically about a regression in Flash 11.3. Unless you believe that the Java issue you're reporting was also caused by Flash 11.3, please file it separately and don't pollute this bug. If you do think that the Java regression was caused by Flash 11.3, please indicate why you think this (did you go back and test with Flash 11.2?).
Comment 30 Dan Q (RedBlade7) 2012-07-02 18:49:32 PDT
Benjamin Smedberg et al, a new bug was filed with these symptoms paraphrased for Java - see #770398.

See my dupe of this bug (#769957) for lots of useful hardware and software info applicable to both this bug (#762948) and the Java equivalent (#770398)
Comment 31 MrX1980 2012-07-08 08:04:37 PDT
Could this be a DirectX 10.1 [HD 4xxx PCIe / GT(X) 2xx PCIe] only problem?
I saw only users with these cards having the problem.
I will test it with my HD 4670 AGP later.

@Jeromie Clark/Adobe: can you confirm this?
Comment 32 gold 2012-07-08 15:53:15 PDT
I sent this a few days ago...
https://bugbase.adobe.com/index.cfm?event=bug&id=3228655
Comment 33 Jim Mathies [:jimm] 2012-07-10 06:35:13 PDT
This is D2D specific as well. GDI doesn't exhibit the problem.
Comment 34 Petras 2012-07-10 07:18:20 PDT
Disabling protected mode in Flash configuration as described in the following page fixed this issue for me:
http://www.pcrx.com/resource_center/how-do-fix-flash-crashes-in-firefox-13.html

According to Adobe, this mode was introduced for Firefox users:
http://blogs.adobe.com/asset/2012/06/inside-flash-player-protected-mode-for-firefox.html

So who then should be blamed for this issue?
Comment 35 Loic 2012-07-13 01:45:11 PDT
*** Bug 773544 has been marked as a duplicate of this bug. ***
Comment 36 Dan Q (RedBlade7) 2012-07-13 20:27:38 PDT
Updated my Flash plugin to 11.3.300.265 and am still having the same problem
Comment 37 Dan Q (RedBlade7) 2012-07-22 16:25:10 PDT
Army of Awesome shows people dumping Firefox in droves over this problem, somebody better fix it soon!
Comment 38 Bas Schouten (:bas.schouten) 2012-07-22 17:47:07 PDT
I can reproduce this on an ATI HD6970, running Windows 7 and Firefox 14.0.1. And Flash player 11.3.300.265. (Firefox is running in Hardware Accelerated mode with Direct3D 10 layers and Direct2D turned on).

This reproduces for me whether Flash GPU acceleration is turned on or off.
Comment 39 Bas Schouten (:bas.schouten) 2012-07-22 18:18:27 PDT
I can also reproduce this on an HD5850. To be honest I can hardly imagine the severity being sufficient to cause people to 'dump firefox in droves', but I will still see if I can get any debug info on the issue.
Comment 40 Dan Q (RedBlade7) 2012-07-22 18:31:29 PDT
(In reply to Bas Schouten (:bas) from comment #39)
>To be honest I can hardly imagine
> the severity being sufficient to cause people to 'dump firefox in droves'

Umm, YouTube?
Comment 41 Bas Schouten (:bas.schouten) 2012-07-22 18:36:18 PDT
Hrm, there's not a lot that can be done here on our side I believe considering the structure of the sandbox. It appears on a scroll the sandboxed child window processes a WM_PAINT and WM_NCPAINT that our own plugin window has as well.

But then it also seems to get an WM_ERASEBKGND after that whose source is not clear to me. Additional invalidation that causes the area to be properly repainted seems to be purely coming from something internal as there are no Window messages sent.

The bottom line is I don't think there's anything we can do here and this is either a Windows or a Flash bug (or a combination of both).
Comment 42 Bas Schouten (:bas.schouten) 2012-07-22 18:40:18 PDT
(In reply to Dan Q (RedBlade7) from comment #40)
> (In reply to Bas Schouten (:bas) from comment #39)
> >To be honest I can hardly imagine
> > the severity being sufficient to cause people to 'dump firefox in droves'
> 
> Umm, YouTube?

The fundamental purpose of Youtube is watching videos. That activity does not seem to be severely affected.

The 'worst-case' scenario I can generate is pick a 4:3 pillarboxed video and pause it, then use scrolling to cause artifacts in the pillars for as long as the video is paused. But that disappear instantly when playing is resumed. That is hardly a critical interference with the user experience on YouTube.

I could see some other applications suffer a little more that regularly only invalidate a small area I suppose. But in reality I doubt there's a lot of users severely affected there either.
Comment 43 Dan Q (RedBlade7) 2012-07-22 19:12:03 PDT
(In reply to Bas Schouten (:bas) from comment #42)
> (In reply to Dan Q (RedBlade7) from comment #40)
> > (In reply to Bas Schouten (:bas) from comment #39)
> > >To be honest I can hardly imagine
> > > the severity being sufficient to cause people to 'dump firefox in droves'
> > 
> > Umm, YouTube?
> 
> The fundamental purpose of Youtube is watching videos. That activity does
> not seem to be severely affected.
> 

Huh?

> The 'worst-case' scenario I can generate is pick a 4:3 pillarboxed video and
> pause it, then use scrolling to cause artifacts in the pillars for as long
> as the video is paused. But that disappear instantly when playing is
> resumed. That is hardly a critical interference with the user experience on
> YouTube.
> 

Most YouTube videos are 4:3. And the top portion of the bars do not re-black-themselves-out when the video is replayed, they still contain the distortion they acquired (or will acquire when scrolling down the page again).

Firefox should work on popular Web sites like YouTube.com out of the box.
Everyday people shouldn't have to deal with hardware acceleration in Preferences, downgrade to an older (insecure?) version of Flash using a special uninstaller, or change something in their video card settings to get YouTube.com to work properly. That's why the Twitter feed contains with messages like "Firefox doesn't work with Flash! I'm switching back to IE/Chrome."

I can't believe any person would claim YouTube.com is too trivial to warrant fixing a serious and embarrassing bug. Getting YouTube.com to work properly should be our top and quick priority right now.
Comment 44 Bas Schouten (:bas.schouten) 2012-07-22 20:28:41 PDT
(In reply to Dan Q (RedBlade7) from comment #43)
> (In reply to Bas Schouten (:bas) from comment #42)
> > (In reply to Dan Q (RedBlade7) from comment #40)
> > > (In reply to Bas Schouten (:bas) from comment #39)
> > > >To be honest I can hardly imagine
> > > > the severity being sufficient to cause people to 'dump firefox in droves'
> > > 
> > > Umm, YouTube?
> > 
> > The fundamental purpose of Youtube is watching videos. That activity does
> > not seem to be severely affected.
> > 
> 
> Huh?

The video is still playing. And is perfectly watchable, i.e. the activity of watching a video is not severely affected.

> Firefox should work on popular Web sites like YouTube.com out of the box.
> Everyday people shouldn't have to deal with hardware acceleration in
> Preferences, downgrade to an older (insecure?) version of Flash using a
> special uninstaller, or change something in their video card settings to get
> YouTube.com to work properly. That's why the Twitter feed contains with
> messages like "Firefox doesn't work with Flash! I'm switching back to
> IE/Chrome."

Then again, we can't fix a bug that we didn't introduce. If you read the history of this bug you would notice several people have spent time on this bug, and all of them have come to the same conclusion, it's most likely not a bug in firefox, it's a bug in Flash. Simply from the fact that it isn't in old flash versions with new firefox versions, but it is in new flash versions with older firefox versions. Adobe has also commented on this bug and said they are working on it, so the bug is most certainly not being ignored, and we'll provide any assistance required, however to the best of my knowledge at this point they've not asked for any.

> I can't believe any person would claim YouTube.com is too trivial to warrant
> fixing a serious and embarrassing bug. Getting YouTube.com to work properly
> should be our top and quick priority right now.

Nobody says the bug shouldn't be fixed. My statements were two-fold:

1. At this point it looks like we can't fix this bug.
2. Although the bug is obviously there, and should be fixed, I doubt it's bad enough to cause people to 'dump firefox in droves'

In any case, let's try and keep the bug focused on any information that might help Adobe find the bug (or help them find out if the update in Flash is simply exposing a bug in firefox that was already there, so we can fix it). At this point as best I can tell the flash sandbox 'window' is completely controlled by them and there is absolutely nothing we can do about this bug, except maybe a hack which generates bogus repaint events but that seems like a very bad approach and might cause all kinds of other performance issues.
Comment 45 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-07-22 20:32:33 PDT
If it was our bug, or it was a Flash bug that we can work around, we'd definitely fix it. But it's a Flash bug with no indication that we can work around it, other than perhaps by forcing the sandboxed mode to be turned off.

We are deeply concerned about this bug and other Flash 11.3 bugs:
https://groups.google.com/d/msg/mozilla.dev.planning/RwpipKzSVBg/XBkuTADEjyoJ
Comment 46 Benjamin Smedberg [:bsmedberg] 2012-07-22 20:55:12 PDT
As I understand the technical commentary here, this bug only affects windowed-mode Flash. Is that correct?

Note that we are tracking at least one other Flash-related painting issue, bug 775724, which is windowless-mode only, but right now the regression range and whether this is a FF or Flash regression is unclear.
Comment 47 Bas Schouten (:bas.schouten) 2012-07-22 20:59:31 PDT
So, I think this might be related to bug 587508 (which I still suspect may be a bug in the windowing system). We added a work-around problem in windows/nsWindow.cpp:6836.

However the invalidate that is sent there might not cause a proper redraw in the Flash player when it is in 'sandboxed' mode.
Comment 48 Bas Schouten (:bas.schouten) 2012-07-22 21:26:47 PDT
Created attachment 644830 [details] [diff] [review]
Workaround for an invalidation problem with flash

I've found a work-around for the problem which I believe to be viable and safe.
Comment 49 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-07-22 21:37:00 PDT
Comment on attachment 644830 [details] [diff] [review]
Workaround for an invalidation problem with flash

Review of attachment 644830 [details] [diff] [review]:
-----------------------------------------------------------------

::: widget/windows/nsWindow.cpp
@@ +6852,5 @@
> +        // side-effects this will have to do for now.
> +        HWND current = (HWND)w->GetNativeData(NS_NATIVE_WINDOW);
> +        POINT p = {0, 0};
> +        while(current != ::ChildWindowFromPoint(current, p)) {
> +          current = ::ChildWindowFromPoint(current, p);

Handle ChildWindowFromPoint returning NULL as well.

I suggest
  while (current) {
    HWND next = ::ChildWindowFromPoint(current, p);
    if (next == current)
      break;
    current = next;
  }

@@ +6861,5 @@
> +        rect.top    = toInvalidate.y;
> +        rect.right  = toInvalidate.XMost();
> +        rect.bottom = toInvalidate.YMost();
> +
> +        ::InvalidateRect(current, &rect, FALSE);

We're going to invalidate the wrong rect here if the child happens to have its top-left not at 0,0. I suggest checking for that in the loop above and only doing this hack for windows that are at 0,0.
Comment 50 Bas Schouten (:bas.schouten) 2012-07-22 23:26:45 PDT
Created attachment 644846 [details] [diff] [review]
Workaround for an invalidation problem with flash v2

I updated the patch and made it more correct. I think I've still seen very subtle artifacts on some very rare occasions but it seems to fix practically all occurrences.
Comment 51 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-07-23 02:04:11 PDT
Comment on attachment 644846 [details] [diff] [review]
Workaround for an invalidation problem with flash v2

Review of attachment 644846 [details] [diff] [review]:
-----------------------------------------------------------------

Just move all this invalidation hackery into its own function please. Call it InvalidatePluginWindowAsWorkaround?
Comment 52 Bas Schouten (:bas.schouten) 2012-07-23 09:36:20 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/d232ed047d58
Comment 53 Jeromie Clark 2012-07-23 13:03:06 PDT
Mozilla folks: Please check these changes against our latest builds to ensure that our fixes don't interact in a negative way.  Sal should be able to get you the latest.
Comment 54 Virtual_ManPL [:Virtual] - (ni? me) 2012-07-23 13:43:51 PDT
FYI - Flash Player 11.4.400.231 Beta 1
http://labs.adobe.com/downloads/flashplayer11-4.html
Comment 55 Bas Schouten (:bas.schouten) 2012-07-23 17:07:33 PDT
Tested against 10.3.300.267 and we're still affected by the bug, and the fix also still works.
Comment 56 Ed Morley [:emorley] 2012-07-24 03:03:11 PDT
https://hg.mozilla.org/mozilla-central/rev/d232ed047d58
Comment 57 Loic 2012-07-24 07:23:21 PDT
(In reply to Bas Schouten (:bas) from comment #55)
> Tested against 10.3.300.267 and we're still affected by the bug, and the fix
> also still works.

Will this workaround be removed from Firefox when a "true" fix will be added to Flash by Adobe?
Comment 58 Benjamin Smedberg [:bsmedberg] 2012-07-24 10:30:20 PDT
Is this workaround limited to Flash plugins or does it affect all plugins? I'd like to land this up the trains as fast as possible, but I'd like to understand the risk a little better.
Comment 59 Bas Schouten (:bas.schouten) 2012-07-24 10:31:30 PDT
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #58)
> Is this workaround limited to Flash plugins or does it affect all plugins?
> I'd like to land this up the trains as fast as possible, but I'd like to
> understand the risk a little better.

This work-around will affect all plugins - however all it does is invalidate additional surface area. In theory the worst-case scenario is a small bit of content getting needlessly redrawn. This might affect performance, but not correctness.
Comment 60 Dan Q (RedBlade7) 2012-07-24 11:46:32 PDT
(In reply to Bas Schouten (:bas) from comment #59)
> 
> This work-around will affect all plugins - however all it does is invalidate
> additional surface area. In theory the worst-case scenario is a small bit of
> content getting needlessly redrawn. This might affect performance, but not
> correctness.

So it will fix bug 770398 (the Java equivalent of this bug) too?
Comment 61 Bas Schouten (:bas.schouten) 2012-07-24 11:48:50 PDT
(In reply to Dan Q (RedBlade7) from comment #60)
> (In reply to Bas Schouten (:bas) from comment #59)
> > 
> > This work-around will affect all plugins - however all it does is invalidate
> > additional surface area. In theory the worst-case scenario is a small bit of
> > content getting needlessly redrawn. This might affect performance, but not
> > correctness.
> 
> So it will fix bug 770398 (the Java equivalent of this bug) too?

It might.
Comment 62 MrX1980 2012-07-24 15:20:09 PDT
(In reply to MrX1980 from comment #16)
> http://www.musikmarkt.de/Aktuell/News/EM-2012-Die-EM-Songs-im-Ueberblick-mit-
> Videos

For me this is fixed.
Would be nice to have this with Firefox 14.0.2 and higher.
Thanks
Comment 63 Jim Mathies [:jimm] 2012-07-25 08:16:20 PDT
(In reply to Ed Morley [:edmorley] from comment #56)
> https://hg.mozilla.org/mozilla-central/rev/d232ed047d58

https://hg.mozilla.org/mozilla-central/rev/887b70a4b6c2

follow up removal of Windows line endings.
Comment 64 Petras 2012-07-30 00:17:16 PDT
Maybe more votes for the issue will force Adobe to fix this issue on their side:
https://bugbase.adobe.com/index.cfm?event=bug&id=3212386
Comment 65 Loic 2012-07-30 04:48:29 PDT
(In reply to Petras from comment #64)
> Maybe more votes for the issue will force Adobe to fix this issue on their
> side:
> https://bugbase.adobe.com/index.cfm?event=bug&id=3212386

This Adobe bug number (3212386) doesn't fit with this one in the title of the current bug (3212446). Is yours correct?
Comment 66 Petras 2012-07-30 06:05:54 PDT
(In reply to Loic from comment #65)
> 
> This Adobe bug number (3212386) doesn't fit with this one in the title of
> the current bug (3212446). Is yours correct?

I can't find an entry to the issue with ID 3212446. I get "The information requested is not found" error: 
https://bugbase.adobe.com/index.cfm?event=bug&id=3212446

Adobe's bugbase Issue 3212386 ("Image Corruption when scrolling with embedded youtubes and some other flash content") I tracked from the comment #32 that links to Adobe issue 3228655, where the reference to that specific issue 3212386 was given.

I see that bug directly linked to what is discussed here. Do you think it's different issue?
Comment 67 gold 2012-07-30 07:27:37 PDT
In the 3228655 issue you find 4 bugs/problems. In that, the 3rd problem is the scrolling problem (yeah something like this: http://i.imgur.com/YKKZY.jpg). But it fixed after I do this 4 steps: http://www.pcrx.com/resource_center/how-do-fix-flash-crashes-in-firefox-13.html and now work normally. I linked these topics, because maybe it has something connection in it's problems.

And I wrote first to the adobe, than they linked this topic first. If they don't linked this topic, I don't know about it.
Comment 68 Petras 2012-07-30 07:56:06 PDT
Well, Adobe didn't fixed the scrolling issue. You have to manually disable Firefox protected mode (introduced in Flash Player v11.3.300.257) as a workaround. Instead, Adobe created an issue 3212386 where it is said that they would not fix it in the next release and it might require more votes to rise it's priority. It is good that Firefox developers will add a workaround as well, but actually it's the Adobe's bug that Adobe must fix.
Comment 69 Bas Schouten (:bas.schouten) 2012-07-30 08:18:23 PDT
Comment on attachment 644846 [details] [diff] [review]
Workaround for an invalidation problem with flash v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Flash 13.3.300.256
User impact if declined: Scrolling artifacts with Flash plugin
Testing completed (on m-c, etc.): mozilla-central
Risk to taking this patch (and alternatives if risky): Relatively low, potentially a small performance impact for some plugins
String or UUID changes made by this patch: None
Comment 70 Jeromie Clark 2012-07-30 09:04:20 PDT
If you are continuing to experience issues, please file a new bug over at http://bugbase.adobe.com/ with a clear description of the problem and steps to reproduce.  We'll be happy to investigate.

Also, please understand that by disabling ProtectedMode, you've permanently disabled modern security protections on your system for all future Flash Player versions.

A better workaround, if you don't need Flash Player 11.x features, is to roll back to Flash Player 10.3.  We maintain this version with current security patches for enterprise customers.

You can find the latest Flash Player 10.3 version here: 
http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html
Comment 71 Alex Keybl [:akeybl] 2012-07-30 12:19:24 PDT
Comment on attachment 644846 [details] [diff] [review]
Workaround for an invalidation problem with flash v2

[Triage Comment]
Helps with new repainting issues in Flash 11.3. My only concern here is that plugin regressions may get lost in the noise of Flash feedback, but the number of reports of this bug specifically is worth the low risk of regression.
Comment 72 Joe Drew (not getting mail) 2012-07-31 10:57:56 PDT
http://hg.mozilla.org/releases/mozilla-beta/rev/52fa7e393866
Comment 73 Joe Drew (not getting mail) 2012-07-31 11:35:45 PDT
http://hg.mozilla.org/releases/mozilla-aurora/rev/28163c015204
Comment 74 chris nuuja 2012-08-01 12:00:53 PDT
(In reply to Joe Drew (:JOEDREW!) from comment #73)
> http://hg.mozilla.org/releases/mozilla-aurora/rev/28163c015204

    I understand there was some concern over performance for this fix?    Fwiw, we can only reproduce this bug when HW accel is enabled in FF, not when its disabled.
Comment 75 chris nuuja 2012-08-01 12:01:20 PDT
(In reply to Joe Drew (:JOEDREW!) from comment #73)
> http://hg.mozilla.org/releases/mozilla-aurora/rev/28163c015204

    I understand there was some concern over performance for this fix?    Fwiw, we can only reproduce this bug when HW accel is enabled in FF, not when its disabled.
Comment 76 Bas Schouten (:bas.schouten) 2012-08-01 17:53:58 PDT
(In reply to chris nuuja from comment #75)
> (In reply to Joe Drew (:JOEDREW!) from comment #73)
> > http://hg.mozilla.org/releases/mozilla-aurora/rev/28163c015204
> 
>     I understand there was some concern over performance for this fix?   
> Fwiw, we can only reproduce this bug when HW accel is enabled in FF, not
> when its disabled.

And only then will we use this workaround.
Comment 77 Ioana (away) 2012-08-10 02:48:32 PDT
Verified as fixed with HW acceleration enabled on:
Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0 (20120731150526)
Flash 11.3.300.268
Comment 78 orangezilla 2012-08-18 09:07:07 PDT
Is this the problem where images of youtube controls or comments can appear to the side of 4:3 videos or is that another bug?
Comment 79 Dan Q (RedBlade7) 2012-08-18 10:58:18 PDT
(In reply to orangezilla from comment #78)
> Is this the problem where images of youtube controls or comments can appear
> to the side of 4:3 videos or is that another bug?

Yes, and sometimes the controls are cut in half.

The bug seems to have returned with recent 15 (beta) updates.
Comment 80 Dan Q (RedBlade7) 2012-08-18 11:16:53 PDT
(In reply to Dan Q (RedBlade7) from comment #79)
> (In reply to orangezilla from comment #78)
> > Is this the problem where images of youtube controls or comments can appear
> > to the side of 4:3 videos or is that another bug?
> 
> Yes, and sometimes the controls are cut in half.
> 
> The bug seems to have returned with recent 15 (beta) updates.

True of Flash 11.3.300.268 and the latest update 11.3.300.271
So it must be a Firefox problem.
Using Firefox 15 Beta, Windows 7 Ultimate 64-bit, GPU is NVIDIA GT 220.
Comment 81 orangezilla 2012-08-18 12:23:46 PDT
Its not fixed in the latest nightly either, not sure if was meant to be?
Comment 82 Alice0775 White 2012-08-18 12:51:09 PDT
I filed a new Bug 783801 with Flash 11.3.300.271
Comment 83 Dan Q (RedBlade7) 2012-08-18 13:16:41 PDT
I'm willing to bet this is an issue with NVIDIA drivers. Everyone here with the problem has NVIDIA cards. Also, we all seem to have forgotten about Bug 770398...
Comment 84 Bas Schouten (:bas.schouten) 2012-08-18 23:36:46 PDT
Fwiw, this work-around is pretty fiddly. If they change their window layout it might need a little nudging.
Comment 85 Mihaela Velimiroviciu (:mihaelav) 2012-09-25 05:47:25 PDT
Verified the fix on:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0, beta 4
Flash: 11.3 and latest 11.4
Comment 86 Ioana (away) 2012-10-12 06:21:13 PDT
Verified as fixed with HW acceleration enabled on:
Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/17.0 Firefox/17.0 (20121010150351)
Flash 11.4.402.287
Comment 87 Jeromie Clark 2012-10-12 10:36:25 PDT
Thanks.  This is also closed/fixed on our side.
Comment 88 Dan Q (RedBlade7) 2012-10-12 11:50:50 PDT
Running Linux x64 with the build:

Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/17.0 Firefox/17.0

Using Slackware 14.0 64-bit, Nouveau driver, and the platform's final Flash 11.2 r202.

NOTE: This is not the Slackware 64-bit package, it was the beta track downloaded off the Mozilla FTP site and updating from there. Slackware uses the stable track which I do not have installed.
Comment 89 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-10-15 10:45:38 PDT
Dan Q, this issue was specific to Flash 11.3 on Windows. Please file a new bug for your specific issue.
Comment 90 Dan Q (RedBlade7) 2012-10-15 13:47:26 PDT
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #89)
> Dan Q, this issue was specific to Flash 11.3 on Windows. Please file a new
> bug for your specific issue.

No bugs here. Just thought I'd enter some helpful information :)
Comment 91 Dan Q (RedBlade7) 2012-10-15 13:48:29 PDT
(In reply to Dan Q (RedBlade7) from comment #88)
> Running Linux x64 with the build:
> 
> Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/17.0 Firefox/17.0
> 
> Using Slackware 14.0 64-bit, Nouveau driver, and the platform's final Flash
> 11.2 r202.
> 
> NOTE: This is not the Slackware 64-bit package, it was the beta track
> downloaded off the Mozilla FTP site and updating from there. Slackware uses
> the stable track which I do not have installed.

Forgot to mention that there were no problems in this build. Maybe thats why you thought it was a bug :)
Comment 92 Benjamin Smedberg [:bsmedberg] 2013-02-12 06:12:15 PST
*** Bug 635065 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.