Last Comment Bug 762982 - when not gczeal(4), MaybeVerifyBarriers shouldn't EndVerifyBarriers if rt->gcVerifyData
: when not gczeal(4), MaybeVerifyBarriers shouldn't EndVerifyBarriers if rt->gc...
Status: RESOLVED FIXED
[js:t]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla16
Assigned To: Bill McCloskey (:billm)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-08 10:39 PDT by Luke Wagner [:luke]
Modified: 2012-06-19 01:18 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (1.51 KB, patch)
2012-06-12 15:36 PDT, Bill McCloskey (:billm)
luke: review+
Details | Diff | Splinter Review

Description Luke Wagner [:luke] 2012-06-08 10:39:34 PDT
Without this, verifybarriers() is less effective since it every call to MaybeVerifyBarriers will effectively inject a verifybarriers() call.
Comment 1 Bill McCloskey (:billm) 2012-06-12 15:36:29 PDT
Created attachment 632447 [details] [diff] [review]
fix
Comment 2 Luke Wagner [:luke] 2012-06-12 16:25:35 PDT
Comment on attachment 632447 [details] [diff] [review]
fix

Sweet, thanks!
Comment 4 Ed Morley [:emorley] 2012-06-19 01:18:45 PDT
https://hg.mozilla.org/mozilla-central/rev/920259bb05e8

Note You need to log in before you can comment on or make changes to this bug.