Last Comment Bug 763148 - put Relation into a11y namespace
: put Relation into a11y namespace
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla16
Assigned To: Mark Capella [:capella]
:
: alexander :surkov
Mentors:
Depends on:
Blocks: namespaceify
  Show dependency treegraph
 
Reported: 2012-06-08 22:47 PDT by alexander :surkov
Modified: 2012-06-12 03:08 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (v1) (7.40 KB, patch)
2012-06-09 21:10 PDT, Mark Capella [:capella]
surkov.alexander: review+
Details | Diff | Splinter Review

Description alexander :surkov 2012-06-08 22:47:31 PDT
file: accessible/src/base/Relation.h, see bug 763146 for the reference
Comment 1 Mark Capella [:capella] 2012-06-09 21:10:07 PDT
Created attachment 631718 [details] [diff] [review]
Patch (v1)

This was interesting ....
Comment 2 alexander :surkov 2012-06-10 04:58:46 PDT
Comment on attachment 631718 [details] [diff] [review]
Patch (v1)

Review of attachment 631718 [details] [diff] [review]:
-----------------------------------------------------------------

::: accessible/src/generic/RootAccessible.h
@@ +18,4 @@
>  namespace mozilla {
>  namespace a11y {
>  
> +class Relation;

you don't really need it since it's defined in Accessible.h, right?

::: accessible/src/msaa/ia2AccessibleRelation.h
@@ +14,5 @@
>  
>  #include "AccessibleRelation.h"
>  
> +namespace mozilla {
> +namespace a11y {

thanks
Comment 3 Mark Capella [:capella] 2012-06-10 11:05:33 PDT
Yes, I was able to pull "relation.h". In the second example I assume you suggest I could also pull "accessiblerelatiio.h", but the build failed without it.
Comment 4 Mark Capella [:capella] 2012-06-10 12:41:54 PDT
TRY push
https://tbpl.mozilla.org/?tree=Try&rev=049e05386514
Comment 5 Mark Capella [:capella] 2012-06-10 15:21:39 PDT
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=a08a067f2713
Comment 6 Graeme McCutcheon [:graememcc] 2012-06-12 03:08:18 PDT
https://hg.mozilla.org/mozilla-central/rev/a08a067f2713

Note You need to log in before you can comment on or make changes to this bug.