Last Comment Bug 763152 - Building against libxul-sdk doesn't link against jemalloc
: Building against libxul-sdk doesn't link against jemalloc
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: All Linux
: -- normal (vote)
: mozilla16
Assigned To: Mike Hommey [:glandium]
:
Mentors:
Depends on:
Blocks: 736564
  Show dependency treegraph
 
Reported: 2012-06-08 23:48 PDT by Mike Hommey [:glandium]
Modified: 2012-06-19 00:04 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Link against libmemory when building against a libxul-sdk that ships it (1.35 KB, patch)
2012-06-08 23:50 PDT, Mike Hommey [:glandium]
khuey: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
Details | Diff | Review

Description Mike Hommey [:glandium] 2012-06-08 23:48:59 PDT
In bug 736564, jemalloc was moved out of mozglue and shipped separately in the sdk. When building against the sdk, we only link against mozglue instead of both mozglue and jemalloc.
Comment 1 Mike Hommey [:glandium] 2012-06-08 23:50:52 PDT
Created attachment 631620 [details] [diff] [review]
Link against libmemory when building against a libxul-sdk that ships it
Comment 3 Matt Brubeck (:mbrubeck) 2012-06-12 18:34:04 PDT
https://hg.mozilla.org/mozilla-central/rev/4a4519b018e9
Comment 4 Mike Hommey [:glandium] 2012-06-15 07:40:08 PDT
Comment on attachment 631620 [details] [diff] [review]
Link against libmemory when building against a libxul-sdk that ships it

[Approval Request Comment]
Bug caused by bug 736564
User impact if declined: Firefox built as a Xulrunner application crashes during startup.
Risk to taking this patch (and alternatives if risky): The patch is NPOTB for anything built at Mozilla.
String or UUID changes made by this patch: None.
Comment 5 Lukas Blakk [:lsblakk] use ?needinfo 2012-06-15 16:17:00 PDT
Comment on attachment 631620 [details] [diff] [review]
Link against libmemory when building against a libxul-sdk that ships it

[Triage Comment]
NPOTB, no problems.
Comment 6 Mike Hommey [:glandium] 2012-06-19 00:04:18 PDT
http://hg.mozilla.org/releases/mozilla-aurora/rev/5f0f44f8cc0e

Note You need to log in before you can comment on or make changes to this bug.