java.lang.NullPointerException: at org.mozilla.gecko.BrowserToolbar$2.onCreateContextMenu(BrowserToolbar.java)

VERIFIED FIXED in Firefox 15

Status

()

Firefox for Android
General
--
critical
VERIFIED FIXED
5 years ago
10 months ago

People

(Reporter: Scoobidiver (away), Assigned: wesj)

Tracking

(4 keywords)

15 Branch
Firefox 16
ARM
Android
crash, regression, reproducible, topcrash
Points:
---

Firefox Tracking Flags

(firefox15 fixed, firefox16 verified)

Details

(Whiteboard: [native-crash], STR in comment #2, crash signature)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
It first appeared in 16.0a1/20120608081921 and has been hit by 3 different users. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7e4c2abb9fc9&tochange=22bb7d46bb23
It's likely a regression from bug 722591.

Here is a crash report: bp-aa6a4d0f-d9b0-484c-a3d4-2f7302120609.

java.lang.NullPointerException
	at org.mozilla.gecko.BrowserToolbar$2.onCreateContextMenu(BrowserToolbar.java:119)
	at android.view.View.createContextMenu(View.java:6322)
	at com.android.internal.view.menu.ContextMenuBuilder.show(ContextMenuBuilder.java:81)
	at com.android.internal.policy.impl.PhoneWindow$DecorView.showContextMenuForChild(PhoneWindow.java:2308)
	at android.view.ViewGroup.showContextMenuForChild(ViewGroup.java:564)
	at android.view.ViewGroup.showContextMenuForChild(ViewGroup.java:564)
	at android.view.ViewGroup.showContextMenuForChild(ViewGroup.java:564)
	at android.view.ViewGroup.showContextMenuForChild(ViewGroup.java:564)
	at android.view.ViewGroup.showContextMenuForChild(ViewGroup.java:564)
	at android.view.ViewGroup.showContextMenuForChild(ViewGroup.java:564)
	at android.view.View.showContextMenu(View.java:3661)
	at android.view.View.performLongClick(View.java:3630)
	at android.widget.TextView.performLongClick(TextView.java:9532)
	at android.view.View$CheckForLongPress.run(View.java:14241)
	at android.os.Handler.handleCallback(Handler.java:605)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:137)
	at android.app.ActivityThread.main(ActivityThread.java:4507)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:790)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:557)
	at dalvik.system.NativeStart.main(Native Method)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NullPointerException%3A+at+org.mozilla.gecko.BrowserToolbar%242.onCreateContextMenu%28BrowserToolbar.java%29
Duplicate of this bug: 763165
(Reporter)

Updated

5 years ago
tracking-fennec: --- → ?
Keywords: topcrash
Steps to Reproduce:

1. Tap and hold on the URL bar
status-firefox16: --- → affected
I was able to reproduce it on the latest Nightly:
https://crash-stats.mozilla.com/report/index/bp-bee5b623-d1f7-4a64-a611-dc8052120611

--
Firefox 16.0a1 (2012-06-10)
Device: Galaxy Nexus
OS: Android 4.0.2
(Reporter)

Updated

5 years ago
Keywords: reproducible
Assignee: nobody → wjohnston

Updated

5 years ago
Whiteboard: [native-crash] → [native-crash], STR in comment #2
(Assignee)

Comment 4

5 years ago
Created attachment 631961 [details] [diff] [review]
Patch

From one of the other bugs....
Attachment #631961 - Flags: review?(mark.finkle)
Comment on attachment 631961 [details] [diff] [review]
Patch

Looks OK, but Sriram should review to make sure we don't need something for other devices.
Attachment #631961 - Flags: review?(sriram)
Attachment #631961 - Flags: review?(mark.finkle)
Attachment #631961 - Flags: review+
Comment on attachment 631961 [details] [diff] [review]
Patch

Review of attachment 631961 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good for me.
menu-v11/ is enough, as that will take care of custom menu inflater in Honeycomb and ICS.
Attachment #631961 - Flags: review?(sriram) → review+
(Assignee)

Comment 7

5 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/07834b62c17c
https://hg.mozilla.org/mozilla-central/rev/07834b62c17c
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 16

Updated

5 years ago
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
status-firefox16: affected → verified
(Assignee)

Comment 9

5 years ago
Comment on attachment 631961 [details] [diff] [review]
Patch

Forgot to request this follow up when pushing the original patch in bug 722591.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 722591
User impact if declined: Crashy
Testing completed (on m-c, etc.): Been on mc for a long time
Risk to taking this patch (and alternatives if risky): Low
String or UUID changes made by this patch: None
Attachment #631961 - Flags: approval-mozilla-aurora?
I just hit this in my first 40 seconds of use of Fennec *ever* (though yes I am using aurora). So nominating for tracking. Its bad UX (imo) for any crasher that is easy to trigger and happens in the first few minutes after first-run.
tracking-fennec: --- → ?
(Reporter)

Updated

5 years ago
status-firefox15: --- → affected
Version: Firefox 16 → Firefox 15

Updated

5 years ago
Attachment #631961 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 11

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/16bb130fb25c
(Reporter)

Updated

5 years ago
status-firefox15: affected → fixed
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.