Closed Bug 763184 Opened 11 years ago Closed 10 years ago

java.lang.ClassCastException: org.mozilla.gecko.AwesomeBarTabs$AwesomeEntryViewHolder cannot be cast to org.mozilla.gecko.AwesomeBarTabs$SearchEntryViewHolder at org.mozilla.gecko.AwesomeBarTabs$AwesomeBarCursorAdapter.getView(AwesomeBarTabs.java)

Categories

(Firefox for Android Graveyard :: General, defect)

16 Branch
ARM
Android
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: scoobidiver, Unassigned)

References

Details

(Keywords: crash, regression, Whiteboard: [native-crash])

Crash Data

There's one crash in 16.0a1/20120609: bp-4bf1f635-1279-40ea-9b13-84bdf2120609. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5891cc95eac7&tochange=95d1bb200f4e
It's likely a regression from bug 757776.

java.lang.ClassCastException: org.mozilla.gecko.AwesomeBarTabs$AwesomeEntryViewHolder cannot be cast to org.mozilla.gecko.AwesomeBarTabs$SearchEntryViewHolder
	at org.mozilla.gecko.AwesomeBarTabs$AwesomeBarCursorAdapter.getView(AwesomeBarTabs.java:762)
	at android.widget.AbsListView.obtainView(AbsListView.java:2012)
	at android.widget.ListView.makeAndAddView(ListView.java:1772)
	at android.widget.ListView.fillSpecific(ListView.java:1318)
	at android.widget.ListView.layoutChildren(ListView.java:1603)
	at android.widget.AbsListView.onLayout(AbsListView.java:1863)
	at android.view.View.layout(View.java:11283)
	at android.view.ViewGroup.layout(ViewGroup.java:4224)
	at android.widget.FrameLayout.onLayout(FrameLayout.java:431)
	at android.view.View.layout(View.java:11283)
	at android.view.ViewGroup.layout(ViewGroup.java:4224)
	at android.widget.LinearLayout.setChildFrame(LinearLayout.java:1628)
	at android.widget.LinearLayout.layoutVertical(LinearLayout.java:1486)
	at android.widget.LinearLayout.onLayout(LinearLayout.java:1399)
	at android.view.View.layout(View.java:11283)
	at android.view.ViewGroup.layout(ViewGroup.java:4224)
	at android.widget.FrameLayout.onLayout(FrameLayout.java:431)
	at android.view.View.layout(View.java:11283)
	at android.view.ViewGroup.layout(ViewGroup.java:4224)
	at android.widget.LinearLayout.setChildFrame(LinearLayout.java:1628)
	at android.widget.LinearLayout.layoutVertical(LinearLayout.java:1486)
	at android.widget.LinearLayout.onLayout(LinearLayout.java:1399)
	at android.view.View.layout(View.java:11283)
	at android.view.ViewGroup.layout(ViewGroup.java:4224)
	at android.widget.FrameLayout.onLayout(FrameLayout.java:431)
	at android.view.View.layout(View.java:11283)
	at android.view.ViewGroup.layout(ViewGroup.java:4224)
	at android.widget.LinearLayout.setChildFrame(LinearLayout.java:1628)
	at android.widget.LinearLayout.layoutVertical(LinearLayout.java:1486)
	at android.widget.LinearLayout.onLayout(LinearLayout.java:1399)
	at android.view.View.layout(View.java:11283)
	at android.view.ViewGroup.layout(ViewGroup.java:4224)
	at android.widget.FrameLayout.onLayout(FrameLayout.java:431)
	at android.view.View.layout(View.java:11283)
	at android.view.ViewGroup.layout(ViewGroup.java:4224)
	at android.view.ViewRootImpl.performTraversals(ViewRootImpl.java:1489)
	at android.view.ViewRootImpl.handleMessage(ViewRootImpl.java:2442)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:137)
	at android.app.ActivityThread.main(ActivityThread.java:4424)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:784)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:551)
	at dalvik.system.NativeStart.main(Native Method)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.ClassCastException%3A+org.mozilla.gecko.AwesomeBarTabs%24AwesomeEntryViewHolder+cannot+be+cast+to+org.mozilla.gecko.AwesomeBarTabs%24SearchEntryViewHolder+at+org.mozilla.gecko.AwesomeBarTabs%24AwesomeBarCursorAdapter.getView%28AwesomeBarTabs.java%29
The regression range doesn't seem to include any of the patches from bug 757776. Am I missing something?
(In reply to Lucas Rocha (:lucasr) from comment #1)
> The regression range doesn't seem to include any of the patches from bug
> 757776. Am I missing something?
It was a guess, assuming there would be other crash reports after, but that hasn't been the case, so the regression range is unknown.
Regression caused by bug 586885?
This crash has occurred on the latest Nightly build, while I was switching the AwesomeBar tabs + tapping on URL bar: 
https://crash-stats.mozilla.com/report/index/f4669dbb-0870-4cee-8aad-3b4f92120612

--
Firefox 16.0a1 (2012-06-11)
Device: Galaxy Nexus
OS: Android 4.0.2
Blocks: 586885
No longer blocks: 757776
Looks like this is gone now - likely fixed by bug 762068.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.