Last Comment Bug 763212 - Build fails with "/bin/sh: line 0: fg: no job control" - related to "%pythonpath" ?
: Build fails with "/bin/sh: line 0: fg: no job control" - related to "%pythonp...
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86_64 Windows 7
: -- blocker (vote)
: mozilla16
Assigned To: Kyle Huey [:khuey] (khuey@mozilla.com)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-09 10:56 PDT by Mats Palmgren (:mats)
Modified: 2012-06-21 09:27 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
mozconfig (176 bytes, text/plain)
2012-06-09 10:57 PDT, Mats Palmgren (:mats)
no flags Details
build log (9.31 KB, text/plain)
2012-06-09 10:58 PDT, Mats Palmgren (:mats)
no flags Details

Description Mats Palmgren (:mats) 2012-06-09 10:56:27 PDT
STEPS TO REPRODUCE
1. clone mozilla-inbound
2. save the attached mozconfig in the working directory
3. mkdir OBJDIR
4. python build/pymake/make.py -f client.mk

ACTUAL RESULT
see attached build log

This is a regression in the past week or so.
Comment 1 Mats Palmgren (:mats) 2012-06-09 10:57:08 PDT
Created attachment 631677 [details]
mozconfig
Comment 2 Mats Palmgren (:mats) 2012-06-09 10:58:24 PDT
Created attachment 631678 [details]
build log
Comment 3 Benjamin Smedberg [:bsmedberg] 2012-06-09 13:52:48 PDT
Yeah, we're trying to use pymake native commands but prefixing the entire thing with PYTHONDONTWRITEBYTECODE=1 which causes pymake to not use native commands. This is a result of bug 741125 (Update WebIDL parser, khuey). But that's not the proximate cause of this; perhaps we started using more pymake native commands in the past week? I can't imagine that replacing PYTHON with % would work in many cases given how we sometimes use it in shell contexts...
Comment 4 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-06-09 13:54:06 PDT
bz switched a bunch of stuff in this directory to use $(PYTHONPATH) instead of $(PYTHON) config/... last week.  Perhaps we should revert that?
Comment 5 Bas Schouten (:bas.schouten) 2012-06-10 11:17:52 PDT
FWIW, the naive workaround here that worked for me is running GNU Make inside 'dom' when I hit that error (which fails pretty quickly if the rest of your objdir isn't up to date). And then running pymake again.
Comment 6 Mark Capella [:capella] 2012-06-10 14:47:50 PDT
WIN7 responds to GNU make with
../config/autoconf.mk:705: *** Windows-style srcdir being used with GNU make. Did you mean to run c:/Users/Master/mozilla-central/build/pymake/make.py instead?
[see-also: https://developer.mozilla.org/en/Gmake_vs._Pymake].  Stop.
No help for the evil ...
Comment 7 Mats Palmgren (:mats) 2012-06-11 18:24:33 PDT
Whatever it was it seems to be fixed now - a clean build from the tip of mozilla-inbound works fine for me.
Comment 8 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-06-11 18:28:04 PDT
Oh, I landed a fix.

http://hg.mozilla.org/mozilla-central/rev/b3e69a65a7b7

Just forgot to mark the bug.
Comment 9 Mats Palmgren (:mats) 2012-06-11 19:12:43 PDT
Thanks Kyle!

Note You need to log in before you can comment on or make changes to this bug.