Last Comment Bug 763242 - Fix freetype detection on Non X11 linux builds
: Fix freetype detection on Non X11 linux builds
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: x86 Linux
: -- normal (vote)
: mozilla16
Assigned To: Oleg Romashin (:romaxa)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-09 19:16 PDT by Oleg Romashin (:romaxa)
Modified: 2012-06-12 18:32 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Check freetype under USE_FC_FREETYPE ifdef (4.21 KB, patch)
2012-06-09 19:16 PDT, Oleg Romashin (:romaxa)
mh+mozilla: review+
Details | Diff | Review
Check freetype under USE_FC_FREETYPE ifdef (5.75 KB, patch)
2012-06-11 13:05 PDT, Oleg Romashin (:romaxa)
mh+mozilla: review+
Details | Diff | Review

Description Oleg Romashin (:romaxa) 2012-06-09 19:16:22 PDT
Created attachment 631711 [details] [diff] [review]
Check freetype under USE_FC_FREETYPE ifdef

On attempt to build on Linux without X11 (cairo-qt for example)
I see message like:
ERROR: Can't find header fontconfig/fcfreetype.h.

I think we should move freetype detection part out of X11 test
Comment 1 Mike Hommey [:glandium] 2012-06-10 22:59:56 PDT
Comment on attachment 631711 [details] [diff] [review]
Check freetype under USE_FC_FREETYPE ifdef

Review of attachment 631711 [details] [diff] [review]:
-----------------------------------------------------------------

::: configure.in
@@ +8858,5 @@
>  
>  if test "$USE_FC_FREETYPE"; then
> +    dnl ========================================================
> +    dnl = Check for freetype2 and its functionality
> +    dnl ========================================================

This needs to be under the COMPILE_ENVIRONMENT test.
Comment 2 Oleg Romashin (:romaxa) 2012-06-11 13:05:23 PDT
Created attachment 631997 [details] [diff] [review]
Check freetype under USE_FC_FREETYPE ifdef

Got build error on try for original patch, due to undefinde CAIRO_FT_FLAGS..

So I moved whole check little bit above that test.
try build for that looks good
https://tbpl.mozilla.org/?tree=Try&rev=ca07bf26a527
Comment 4 Matt Brubeck (:mbrubeck) 2012-06-12 18:32:27 PDT
https://hg.mozilla.org/mozilla-central/rev/0890dcf220c7

Note You need to log in before you can comment on or make changes to this bug.