Last Comment Bug 763348 - assertion errors in worker tests
: assertion errors in worker tests
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86_64 Linux
: -- critical (vote)
: mozilla16
Assigned To: :Benjamin Peterson
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-10 14:11 PDT by :Benjamin Peterson
Modified: 2012-06-13 05:57 PDT (History)
2 users (show)
ryanvm: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (909 bytes, patch)
2012-06-11 17:37 PDT, :Benjamin Peterson
jorendorff: review+
Details | Diff | Splinter Review

Description :Benjamin Peterson 2012-06-10 14:11:11 PDT
$ ./configure --enable-debug --disable-optimize --enable-threadsafe --with-system-nspr
$ tests/jstests.py _DBG.OBJ/js worker -o
    rc = 0, run time = 0.034421
 PASSED! worker-error

jstest: undefined bug:  result: PASSED type: shell description: worker-error reason: 

    rc = 0, run time = 0.052837
 PASSED! worker-init

jstest: undefined bug:  result: PASSED type: shell description: worker-init reason: 

    rc = -11, run time = 0.049652
Assertion failure: JSVAL_IS_DOUBLE(v), at ../../jsapi.h:1927
REGRESSION - js1_8_5/extensions/worker-terminate.js
    rc = -11, run time = 0.064559
Assertion failure: JSVAL_IS_DOUBLE(v), at ../../jsapi.h:1927
REGRESSION - js1_8_5/extensions/worker-fib.js
    rc = 0, run time = 0.063370
 PASSED! worker-simple

jstest: undefined bug:  result: PASSED type: shell description: worker-simple reason: 

    rc = 0, run time = 0.059212
 PASSED! typeof event.message

jstest: undefined bug:  result: PASSED type: shell description: typeof event.message reason: 

    rc = 6, run time = 1.040414
--- NOTE: IN THIS TESTCASE, WE EXPECT EXIT CODE 6 ---
Script runs for too long, terminating.
REGRESSIONS
    js1_8_5/extensions/worker-terminate.js
    js1_8_5/extensions/worker-fib.js
FAIL
Comment 1 :Benjamin Peterson 2012-06-11 17:37:02 PDT
Created attachment 632083 [details] [diff] [review]
fix

Looks like a simple oversight. (Are the tests for this thing never run?)
Comment 2 :Benjamin Peterson 2012-06-11 18:47:48 PDT
Evidently bustage from bug 697537.
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-06-12 18:38:33 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/1eb234066998
Comment 4 Ed Morley [:emorley] 2012-06-13 05:57:37 PDT
https://hg.mozilla.org/mozilla-central/rev/1eb234066998

Note You need to log in before you can comment on or make changes to this bug.