Change mouse pointer when selecting a link to a new window

VERIFIED DUPLICATE of bug 14027

Status

SeaMonkey
General
--
enhancement
VERIFIED DUPLICATE of bug 14027
17 years ago
14 years ago

People

(Reporter: Tony Tovar, Assigned: Matthew Paul Thomas)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Currently, when you point at a link, the Mozilla mouse pointer changes from a
generic pointer to a link pointer. There is not, however, any differentiation
between regular links and links which will open a new window.  

So, I would like to suggest that Mozilla use an alternate link pointer when you
point at a link which will open a new window.

(FYI - When you click SEARCH on the Mozilla bug-search page, it also opens a new
window, but I don't think this is a good example of my enhancement request since
form buttons don't cause the link pointer to appear.)

Comment 1

17 years ago
Whoa, good idea!

Comment 2

17 years ago
Marking NEW.
Assignee: asa → mpt
Status: UNCONFIRMED → NEW
Component: Browser-General → User Interface Design
Ever confirmed: true
QA Contact: doronr → zach

Comment 3

17 years ago
yes, we should try to do this, however it won't work perfectly (javascript urls 
can do anything they like, and testdriving is not worth it), this will probably 
not work on all platforms.

There are three or four states:
target=_new, target=somesiblingframe, 
target=existingnamedframeThatisNotAsibling, target=inline

Ideally, we'd have different classes for each of these, and by default most of 
them would share cursors.
(Assignee)

Comment 4

17 years ago
The basic problem is to indicate whether or not a link will open in a new 
window, before the user clicks the link. This bug and bug 14027 suggest 
different implementations; I've resummarized bug 14027 to be
non-implementation-specific, and I'll mark this as a dup since these two bugs 
will either be mutually exclusive or will be resolved at the same time.

*** This bug has been marked as a duplicate of 14027 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
/me trys to be a good qa contact
Status: RESOLVED → VERIFIED

Updated

16 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.