Login form not detected if dynamically created

RESOLVED DUPLICATE of bug 355063

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 355063
6 years ago
6 years ago

People

(Reporter: Mauro Molinari, Unassigned)

Tracking

10 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Opera/9.80 (Windows NT 6.1; WOW64; U; it) Presto/2.10.229 Version/11.64

Steps to reproduce:

- enable Password Manager Debugging as per https://wiki.mozilla.org/Firefox%3aPassword_Manager_Debugging
- go to http://www.utopicmusic.com
- click on "Login"


Actual results:

The login form is not detected by Firefox. This means that, if you have an account, username and password are not pre-filled.
The submit form is actually detected by Firefox once you submit it (i.e.: Firefox asks you to save your password or to update it if you type in a different one), however the next time you come back to the site, the autocompletion of username & password still doesn't work.

You may try to register to that site as a Listener to test login and logout operations. Registration is free.


Expected results:

Even if the login form is dynamically created when you click on "Login" and the login form is displayed, Firefox should correctly detect and recognize it for username & password autocompletion.

This problem of dynamically created login form not being recognized is known by other users, as documented at:
http://stackoverflow.com/a/2700066 (point 2) and http://stackoverflow.com/a/10941073

Please note that the login form is correctly recognized and handled by the Opera browser.
(Reporter)

Comment 2

6 years ago
Yes, it's a duplicate of 355063, sorry.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 355063
You need to log in before you can comment on or make changes to this bug.