VKB is not dismissed when switching tabs

VERIFIED FIXED in Firefox 18

Status

()

Firefox for Android
General
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: Paul Feher, Assigned: bnicholson)

Tracking

16 Branch
Firefox 16
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox18 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Nightly Fennec 16.0a1 (2012-06-10)
Device: HTC Desire Z 
OS: Android 2.3.3

Steps to Reproduce:
1. Open two or more pages in different tabs.
2. Open a new tab and load a page that contains a text input field and tap on it for the VKB to appear (ex: google.com)
3. Open the tab menu and switch to another tab.

Expected:
The VKB is dismissed.

Actual:
The VKB is not dismissed.
(Reporter)

Updated

6 years ago
blocking-fennec1.0: --- → ?
Assignee: nobody → bnicholson

Updated

6 years ago
Blocks: 739407
blocking-fennec1.0: ? → ---
(Assignee)

Comment 1

6 years ago
Created attachment 631995 [details] [diff] [review]
patch
Attachment #631995 - Flags: review?(mark.finkle)
> Step #3: "Open the tab menu and switch to another tab."

Shouldn't we have the fix in Tabs.selectTab(...) ?
(Assignee)

Comment 3

6 years ago
(In reply to Mark Finkle (:mfinkle) from comment #2)
> > Step #3: "Open the tab menu and switch to another tab."
> 
> Shouldn't we have the fix in Tabs.selectTab(...) ?

That means the keyboard would still be visible when we click the tabs tray button and until the user actually selects a tab, which can potentially hide some of the tabs in the tabs tray. This patch should put us back the previous behavior before the regression from bug 739407, but we can also put this in selectTab() for tabs that are changed programmatically.
IMO the VKB should be dismissed as soon as the tabs menu is invoked, for the reasons you already mentioned, Brian.
Duplicate of this bug: 764729

Comment 6

6 years ago
I can reproduce in Galaxy S2 using Android 2.3.4 and Nightly 20120618. 
I think it's worth to fix because the VKB should be dismissed as soon as the tabs menu is invoked, as stated above
tracking-fennec: --- → ?
Comment on attachment 631995 [details] [diff] [review]
patch


>     private void toggleTabs() {
>         if (GeckoApp.mAppContext.areTabsShown())
>             GeckoApp.mAppContext.hideTabs();
>-        else
>+        else {
>+            InputMethodManager imm =
>+                    (InputMethodManager) mContext.getSystemService(Context.INPUT_METHOD_SERVICE);
>+            imm.hideSoftInputFromWindow(mTabs.getWindowToken(), 0);
>             GeckoApp.mAppContext.showLocalTabs();
>+        }

the "if" block needs {} now too:

if () {
} else {
}

Also, we need a bug for closing the keyboard in selectTab
Attachment #631995 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 9

6 years ago
(In reply to Mark Finkle (:mfinkle) from comment #7)
> Also, we need a bug for closing the keyboard in selectTab

Filed bug 767147.
https://hg.mozilla.org/mozilla-central/rev/e031f55fd997
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 16
This issue is not longer reproducible on the latest Nightly build. Closing bug as verified fixed on:

Firefox 18.0a1 (2012-09-12)
Device: Galaxy Note
OS: Android 4.0.4
Status: RESOLVED → VERIFIED
status-firefox18: --- → verified
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.