Last Comment Bug 763411 - Elements cut-off in preferences dialog for rm locale
: Elements cut-off in preferences dialog for rm locale
Status: RESOLVED FIXED
[mozmill-l10n]
:
Product: Mozilla Localizations
Classification: Client Software
Component: rm / Romansh (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Gion-Andri Cantieni [:gion-andri]
:
Mentors:
http://mozmill-ci.blargon7.com/#/l10n...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-11 02:22 PDT by Henrik Skupin (:whimboo)
Modified: 2012-07-18 08:58 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed
fixed


Attachments
screenshot (16.85 KB, image/jpeg)
2012-07-18 05:22 PDT, Henrik Skupin (:whimboo)
no flags Details
Screenshot with rounded border (7.91 KB, image/png)
2012-07-18 05:36 PDT, Gion-Andri Cantieni [:gion-andri]
no flags Details

Description Henrik Skupin (:whimboo) 2012-06-11 02:22:42 PDT
Our Mozmill l10n tests have been shown that there are some elements which are cut-off due to the localization. The results of the test you can find here:

http://mozmill-ci.blargon7.com/#/l10n/report/ee284dfa9d664754a65676abbc00d413

Details:

 Node is cut off by 15 px at the bottom: listitem#en. Parent node: listboxbody[rows=6][xbl:inherits=rows,size,minheight]
Node is cut off by 12 px at the bottom: tabbox#advancedPrefs. Parent node: vbox[xbl:inherits=flex][class=content-box]
Node is cut off by 12 px at the bottom: tabbox#advancedPrefs. Parent node: vbox[xbl:inherits=flex][class=content-box]
Node is cut off by 12 px at the bottom: tabbox#advancedPrefs. Parent node: vbox[xbl:inherits=flex][class=content-box]
Node is cut off by 12 px at the bottom: tabbox#advancedPrefs. Parent node: vbox[xbl:inherits=flex][class=content-box]
Comment 1 Gion-Andri Cantieni [:gion-andri] 2012-07-16 07:11:34 PDT
(In reply to Henrik Skupin (:whimboo) from comment #0)
> Node is cut off by 15 px at the bottom: listitem#en. Parent node:
> listboxbody[rows=6][xbl:inherits=rows,size,minheight]

This is a false positive caused by bug 763461 (list in language-choose-window). 

> Node is cut off by 12 px at the bottom: tabbox#advancedPrefs. Parent node:
> vbox[xbl:inherits=flex][class=content-box]
> Node is cut off by 12 px at the bottom: tabbox#advancedPrefs. Parent node:
> vbox[xbl:inherits=flex][class=content-box]
> Node is cut off by 12 px at the bottom: tabbox#advancedPrefs. Parent node:
> vbox[xbl:inherits=flex][class=content-box]
> Node is cut off by 12 px at the bottom: tabbox#advancedPrefs. Parent node:
> vbox[xbl:inherits=flex][class=content-box]

These errors appear because the string 'offlineNotify.label' is too long. Maybe we could shorten it to "Confermar, sche websites vulan memorisar datas per l'utilisaziun offline." I'll discuss this in the team. 

Thanks Henrik for your help.
Comment 2 Gion-Andri Cantieni [:gion-andri] 2012-07-18 00:33:33 PDT
Fixed in 
http://hg.mozilla.org/releases/l10n/mozilla-aurora/rm/rev/9f43a411b359
Comment 3 Henrik Skupin (:whimboo) 2012-07-18 05:22:34 PDT
It's better but not enough. The rounded border at the bottom is still not present. I will attach a screenshot.
Comment 4 Henrik Skupin (:whimboo) 2012-07-18 05:22:45 PDT
Created attachment 643329 [details]
screenshot
Comment 5 Gion-Andri Cantieni [:gion-andri] 2012-07-18 05:36:16 PDT
Created attachment 643335 [details]
Screenshot with rounded border

On my machine, with changed string, the rounded border is there. But there isn't an Aurora-build with the commit yet. 
How did you do this screenshot?
Comment 6 Henrik Skupin (:whimboo) 2012-07-18 06:56:47 PDT
No, there is no rounded border in your screenshot. What I mean is the groupbox, which is the small border right above the question mark.

The Aurora build I have used is:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-aurora-l10n/firefox-16.0a2.ro.mac.dmg
Comment 7 Henrik Skupin (:whimboo) 2012-07-18 07:33:50 PDT
Sorry my fault. The Aurora build I was using haven't had this change included. Latest tinderbox build works fine.
Comment 8 Gion-Andri Cantieni [:gion-andri] 2012-07-18 07:59:11 PDT
I also pushed this change to beta: 
http://hg.mozilla.org/releases/l10n/mozilla-beta/rm/rev/aeaf8151847b

Note You need to log in before you can comment on or make changes to this bug.