If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Thunderbird Earlybird builds broken due to length of directories (add "comm" to the reallyShort replacement list)

RESOLVED FIXED

Status

Release Engineering
General Automation
--
major
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 631836 [details] [diff] [review]
Proposed fix

Thunderbird Earlybird Windows opt builds (comm-aurora) are currently broken due to the file names being too long.

Although this is being worked on in bug 757252, there is a delay there and I don't know if we are going to be able to backport it. In the meantime, we need to get the aurora Windows builds working asap.

From my calculations, if we add "comm" -> "c" to the reallyShort list for mappings of object directories, then we should at least get opt builds working again.

We might still have broken debug builds on Earlybird Windows, but I'm happy to re-assess those once we see where bug 757252 is going.
Attachment #631836 - Flags: review?(jhopkins)
(Assignee)

Updated

5 years ago
Duplicate of this bug: 762623
Attachment #631836 - Flags: review?(jhopkins) → review+
(Assignee)

Comment 2

5 years ago
Comment on attachment 631836 [details] [diff] [review]
Proposed fix

Checked in:

http://hg.mozilla.org/build/buildbotcustom/rev/b25a4046025b
Attachment #631836 - Flags: checked-in+
found in triage.
Assignee: mbanner → nobody
Component: Release Engineering → Release Engineering: Automation (General)
QA Contact: release → catlee
(Assignee)

Updated

5 years ago
Assignee: nobody → mbanner
deployed to production
(Assignee)

Comment 5

5 years ago
Excellent, this seems to have worked fine and un-broken our builds for now.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.