Fennec's Menu doesn't scroll correctly if Tabs Menu list is opened

RESOLVED FIXED

Status

()

Firefox for Android
General
RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: xti, Assigned: sriram)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 631866 [details]
screenshot 1

Firefox 16.0a1 (2012-06-11)
Device: Galaxy Nexus
OS: Android 4.0.2

Steps to reproduce:
1. Open Fennec
2. Open at least 2-3 webpages, each one in a new tab
3. Tap on Tabs Menu
4. Tap on Fennec's Menu button
5. Scroll down the App's Menu and tap on Settings

Expected result:
Menu is fully scrollable

Actual result:
At step 5, scroll is locked on the top half (see screenshot 1)

Note: 
In landscape, the Fennec's Menu is unusable at step 4 (see screenshot 2)
(Reporter)

Updated

6 years ago
OS: Windows 7 → Android
Hardware: x86 → ARM
Version: Firefox 14 → Trunk
(Reporter)

Comment 1

6 years ago
Created attachment 631867 [details]
screenshot 2
Assignee: nobody → sriram

Updated

6 years ago
Blocks: 739407
(Assignee)

Comment 2

6 years ago
This will change with bug 763049.
(In reply to Sriram Ramasubramanian [:sriram] from comment #2)
> This will change with bug 763049.

Did bug 763049 really change anything regarding this bug? I don't think so, I still cannot scroll to the bottom of the menu.
(Assignee)

Comment 4

6 years ago
I idea is not to scroll to the bottom of the page, as the whole tab window slides down. This is a new context mode, that is basically not for browsing the page -- but to switch tabs.
(In reply to Sriram Ramasubramanian [:sriram] from comment #4)
> I idea is not to scroll to the bottom of the page, as the whole tab window
> slides down. 

I see your point but this is still weird. With the page fully visible, the menu shows 10 items and I need to scroll one down to get to the bottom of the menu. When tabs are shown, the menu shows three and a half items and I can still move only one down. The fact that the menu does not touch the bottom of the screen (as shown in screenshot 1) destroys the intended effect you describe.

To make this useful, there are two options:

a) show as much of the menu as possible (all the way to the bottom of the screen) and keep the menu open when the tab button is pressed to get back to the page view.

b) close the tab view when the menu button is pressed and show the full menu.

I think I would prefer b)
(Reporter)

Comment 6

6 years ago
(In reply to Michael Monreal [:monreal] from comment #5)

> I think I would prefer b)

It looks like the best solution in this case imo. There is no useful reason to use the Fennec's Menu while the Tabs Menu is still opened.
(Reporter)

Updated

6 years ago
Duplicate of this bug: 774515
This was fixed when Fennec's Menu button was removed from the Tab menu list. (Can't find the bug that did that)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.