The default bug view has changed. See this FAQ.

Bookmarks Manager has lost its icons

RESOLVED FIXED in seamonkey2.13

Status

SeaMonkey
Bookmarks & History
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: neil@parkwaycc.co.uk)

Tracking

({regression})

Trunk
seamonkey2.13
regression
Bug Flags:
in-testsuite -

SeaMonkey Tracking Flags

(seamonkey2.10 wontfix, seamonkey2.11 fixed, seamonkey2.12 fixed)

Details

Attachments

(3 attachments)

(Assignee)

Description

5 years ago
The Bookmarks manager window and the bookmark properties dialog used to have custom window icons, but these stopped working when the appropriate windows were given new ids by bug 580662. I guess it's too late to change the ids back, so we have to rename the icons instead. I don't know how the Mac works though.
(Assignee)

Comment 1

5 years ago
Created attachment 631894 [details] [diff] [review]
Proposed patch
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #631894 - Flags: review?(iann_bugzilla)

Comment 2

5 years ago
Comment on attachment 631894 [details] [diff] [review]
Proposed patch

r=me assuming you get a ui-review from a mac person
Attachment #631894 - Flags: review?(iann_bugzilla) → review+

Comment 3

5 years ago
Mac doesn't make use of window icons and the the Mac icons in suite/branding/nightly/icons/mac/ are handled in suite/app/macbuild/Contents/Info.plist.in, so you can just move on :-)
(Assignee)

Comment 4

5 years ago
Pushed comm-central changeset b12ec5c00ac0.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

5 years ago
Comment on attachment 631894 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): 580662
User impact if declined: Cosmetic
Testing completed (on m-c, etc.): None
Risk to taking this patch (and alternatives if risky): Low (build fix)
String changes made by this patch: None
Attachment #631894 - Flags: approval-comm-beta?
Attachment #631894 - Flags: approval-comm-aurora?

Comment 6

5 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1339686418.1339695615.3577.gz&fulltext=1

make[3]: *** [stage-package] Error 255

Error: package error or possible missing or unnecessary file: bin/chrome/icons/default/bmPropsWindow.png (package-manifest, 348).
Error: package error or possible missing or unnecessary file: bin/chrome/icons/default/bmPropsWindow16.png (package-manifest, 349).
Error: package error or possible missing or unnecessary file: bin/chrome/icons/default/bmPropsWindow48.png (package-manifest, 350).
Error: package error or possible missing or unnecessary file: bin/chrome/icons/default/bookmark-window.png (package-manifest, 351).
Error: package error or possible missing or unnecessary file: bin/chrome/icons/default/bookmark-window16.png (package-manifest, 352).
Error: package error or possible missing or unnecessary file: bin/chrome/icons/default/bookmark-window48.png (package-manifest, 353).
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 7

5 years ago
Comment on attachment 631894 [details] [diff] [review]
Proposed patch

FYI: Packaging errors are now fatal.
Attachment #631894 - Flags: approval-comm-beta?
Attachment #631894 - Flags: approval-comm-beta-
Attachment #631894 - Flags: approval-comm-aurora?
Attachment #631894 - Flags: approval-comm-aurora-

Comment 8

5 years ago
> FYI: Packaging errors are now fatal.
(Assignee)

Comment 9

5 years ago
Created attachment 633422 [details] [diff] [review]
Packaging fix?
Attachment #633422 - Flags: review?(sgautherie.bz)
Comment on attachment 633422 [details] [diff] [review]
Packaging fix?

I skimmed it, and looks fine, and briefly compared against win
Attachment #633422 - Flags: review?(sgautherie.bz) → review+

Updated

5 years ago
Attachment #631894 - Flags: approval-comm-beta?
Attachment #631894 - Flags: approval-comm-beta-
Attachment #631894 - Flags: approval-comm-aurora?
Attachment #631894 - Flags: approval-comm-aurora-
(Assignee)

Comment 11

5 years ago
Pushed comm-central changeset 4cf03f36c629.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

5 years ago
Created attachment 633982 [details] [diff] [review]
Rolled-up patch for branch

[Approval Request Comment]
Regression caused by (bug #): 580662
User impact if declined: Cosmetic
Testing completed (on m-c, etc.): Landed and bustage fixed
Risk to taking this patch (and alternatives if risky): Low (bustage fixed)
String changes made by this patch: None
Attachment #633982 - Flags: approval-comm-beta?
Attachment #633982 - Flags: approval-comm-aurora?
Attachment #631894 - Flags: approval-comm-beta?
Attachment #631894 - Flags: approval-comm-aurora?
status-seamonkey2.10: --- → wontfix
status-seamonkey2.11: --- → affected
status-seamonkey2.12: --- → affected
Flags: in-testsuite-
Target Milestone: --- → seamonkey2.13

Updated

5 years ago
Attachment #633982 - Flags: approval-comm-beta?
Attachment #633982 - Flags: approval-comm-beta+
Attachment #633982 - Flags: approval-comm-aurora?
Attachment #633982 - Flags: approval-comm-aurora+
(Assignee)

Comment 13

5 years ago
Pushed comm-aurora changeset 754df5de175b.
Pushed comm-beta changeset 2a9603a85385.
status-seamonkey2.11: affected → fixed
status-seamonkey2.12: affected → fixed
You need to log in before you can comment on or make changes to this bug.