Last Comment Bug 763559 - Enable WEBGL_compressed_texture_s3tc for machines using Angle
: Enable WEBGL_compressed_texture_s3tc for machines using Angle
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: 16 Branch
: x86_64 Windows 7
: -- normal (vote)
: mozilla16
Assigned To: Benoit Jacob [:bjacob] (mostly away)
:
:
Mentors:
Depends on: 728017
Blocks: gecko-games
  Show dependency treegraph
 
Reported: 2012-06-11 10:33 PDT by michaelbraithwaite
Modified: 2012-08-15 12:43 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
fix s3tc extension on ANGLE (2.77 KB, patch)
2012-06-14 11:44 PDT, Benoit Jacob [:bjacob] (mostly away)
jgilbert: review+
Details | Diff | Splinter Review
fix s3tc extension on ANGLE (updated for landing) (2.77 KB, patch)
2012-06-14 20:07 PDT, Benoit Jacob [:bjacob] (mostly away)
jacob.benoit.1: review+
Details | Diff | Splinter Review
fix s3tc extension on ANGLE (updated for landing) (3.03 KB, patch)
2012-06-14 20:24 PDT, Benoit Jacob [:bjacob] (mostly away)
jacob.benoit.1: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description michaelbraithwaite 2012-06-11 10:33:42 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.56 Safari/536.5

Steps to reproduce:

Following on from https://bugzilla.mozilla.org/show_bug.cgi?id=728017

* Run nightly 16.0a1 on a machine that uses Angle for WebGL (eg Windows 7 ATI 6800 with catalyist 12.3)

* Look at the WebGL supported extension and it list "Extensions: OES_texture_float OES_standard_derivatives MOZ_WEBGL_lose_context"

* If I force native GL using about:config and it then lists "Extensions: OES_texture_float OES_standard_derivatives MOZ_EXT_texture_filter_anisotropic MOZ_WEBGL_lose_context MOZ_WEBGL_compressed_texture_s3tc"





Actual results:

No MOZ_WEBGL_compressed_texture_s3tc support


Expected results:

MOZ_WEBGL_compressed_texture_s3tc support as Angle supports the required features.
Comment 1 Benoit Jacob [:bjacob] (mostly away) 2012-06-14 11:44:38 PDT
Created attachment 633214 [details] [diff] [review]
fix s3tc extension on ANGLE

Many thanks for the report, this is really important and had escaped us. Chromium is doing the same thing here.
Comment 2 Benoit Jacob [:bjacob] (mostly away) 2012-06-14 12:30:41 PDT
Oh right --- Michael: the category for WebGL bugs is Core -> Canvas:WebGL, correct categorization helps a lot avoiding bugs getting forgotten about.

Gavin: what can we do to help with the problem that most people don't understand what 'Core' is and just file all their bugs into Firefox, and then obviously can't find the Gecko categories they're looking for under Firefox, so they end up filing in Firefox->General or Untriaged?

The bugzilla homepage already says this about Core:

"Shared components used by Firefox and other Mozilla software, including handling of Web content (HTML, CSS, scripts, images, networking, etc.)."

Maybe we could have a notice under Firefox reminding people that "handling of Web content" does NOT belong there?
Comment 3 Jeff Gilbert [:jgilbert] 2012-06-14 16:49:20 PDT
Comment on attachment 633214 [details] [diff] [review]
fix s3tc extension on ANGLE

Review of attachment 633214 [details] [diff] [review]:
-----------------------------------------------------------------

A nit for consideration.

::: content/canvas/src/WebGLContext.cpp
@@ +859,5 @@
>          case WebGL_WEBGL_compressed_texture_s3tc:
> +            isSupported = gl->IsExtensionSupported(GLContext::EXT_texture_compression_s3tc) ||
> +                          (gl->IsExtensionSupported(GLContext::EXT_texture_compression_dxt1) &&
> +                           gl->IsExtensionSupported(GLContext::ANGLE_texture_compression_dxt3) &&
> +                           gl->IsExtensionSupported(GLContext::ANGLE_texture_compression_dxt5));

This would probably be more readable as two separate if() statements, but it's...acceptable as-is.
Comment 5 Martin Best (:mbest) 2012-06-14 19:50:26 PDT
Should we try and get this in fx15?
Comment 6 Benoit Jacob [:bjacob] (mostly away) 2012-06-14 19:51:57 PDT
Martin: Yes of course!
Comment 7 Martin Best (:mbest) 2012-06-14 19:57:39 PDT
Looks like 15 may still be on trunk but I'll check with Alex to see if we need to nominated it.
Comment 8 Benoit Jacob [:bjacob] (mostly away) 2012-06-14 19:59:32 PDT
Trunk has been 16 for a week now and 15 is aurora. But this is such a low-risk and high-importance fix that I have no doubt that we'll get aurora approval. Aurora approval early in the cycle isn't that hard to get.
Comment 9 Benoit Jacob [:bjacob] (mostly away) 2012-06-14 20:07:37 PDT
Created attachment 633369 [details] [diff] [review]
fix s3tc extension on ANGLE (updated for landing)

Updated to follow Jeff's recommendation.
Comment 10 Benoit Jacob [:bjacob] (mostly away) 2012-06-14 20:18:50 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/3159f0528301
Comment 11 Benoit Jacob [:bjacob] (mostly away) 2012-06-14 20:21:51 PDT
Comment on attachment 633369 [details] [diff] [review]
fix s3tc extension on ANGLE (updated for landing)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): not a regression, but it makes the benefits of S3TC compressed textures (landed in bug 728017) unavailable to Windows users.
User impact if declined: No s3tc compressed texture support for Windows users in default configuration. That really sucks: s3tc compressed textures is THE most important missing WebGL feature, it's required to be serious players in the Games area, and we were looking forward to announce support to that in Firefox 15.
Testing completed (on m-c, etc.): Just landed on m-i
Risk to taking this patch (and alternatives if risky): Not risky at all. Look at the patch, it's really trivial.
String or UUID changes made by this patch: none
Comment 12 Benoit Jacob [:bjacob] (mostly away) 2012-06-14 20:24:15 PDT
Created attachment 633375 [details] [diff] [review]
fix s3tc extension on ANGLE (updated for landing)

Sorry, this is the patch that I actually landed.
Comment 13 Benoit Jacob [:bjacob] (mostly away) 2012-06-14 20:24:34 PDT
Comment on attachment 633375 [details] [diff] [review]
fix s3tc extension on ANGLE (updated for landing)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): not a regression, but it makes the benefits of S3TC compressed textures (landed in bug 728017) unavailable to Windows users.
User impact if declined: No s3tc compressed texture support for Windows users in default configuration. That really sucks: s3tc compressed textures is THE most important missing WebGL feature, it's required to be serious players in the Games area, and we were looking forward to announce support to that in Firefox 15.
Testing completed (on m-c, etc.): Just landed on m-i
Risk to taking this patch (and alternatives if risky): Not risky at all. Look at the patch, it's really trivial.
String or UUID changes made by this patch: none
Comment 14 Ed Morley [:emorley] 2012-06-15 05:56:41 PDT
https://hg.mozilla.org/mozilla-central/rev/3159f0528301
Comment 15 Lukas Blakk [:lsblakk] use ?needinfo 2012-06-15 16:33:44 PDT
Comment on attachment 633375 [details] [diff] [review]
fix s3tc extension on ANGLE (updated for landing)

[Triage Comment]
With an approval request like that, how could we say no?  Low risk, gets us better gaming on Windows - approved for Aurora.
Comment 16 Benoit Jacob [:bjacob] (mostly away) 2012-06-15 22:56:22 PDT
Thanks!

http://hg.mozilla.org/releases/mozilla-aurora/rev/ac587e102ae8
Comment 17 Benoit Jacob [:bjacob] (mostly away) 2012-08-15 11:26:50 PDT
How is this dev-doc-needed? This landed in 15 just like s3tc support itself.
Comment 18 :Ehsan Akhgari 2012-08-15 12:03:09 PDT
(In reply to comment #17)
> How is this dev-doc-needed? This landed in 15 just like s3tc support itself.

Is it covered by the same documentation?
Comment 19 Benoit Jacob [:bjacob] (mostly away) 2012-08-15 12:11:00 PDT
My point is from the point of view of dev-docs, there is only 1 feature to document: s3tc textures. There is no need to enter into platform-specific details as this support landed on all OSes in the same version.
Comment 20 :Ehsan Akhgari 2012-08-15 12:43:38 PDT
Understood and agreed!

Note You need to log in before you can comment on or make changes to this bug.