Form autocomplete text is not inserted when used twice in a row

RESOLVED FIXED

Status

()

Firefox for Android
General
P3
normal
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: cpeterson, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox14 wontfix, firefox15 wontfix, firefox16 wontfix, firefox17 wontfix, firefox18 wontfix, firefox19 wontfix, firefox20 affected, firefox21 affected, firefox22 affected, firefox23 verified, firefox24 verified)

Details

(Reporter)

Description

6 years ago
STR:
1. My form autocomplete history has two entries and one is a prefix of the other: "hello" and "hello world".
2. In Fennec, tap input focus to a text input form.
3. From autocomplete popup, select the prefix entry "hello".
4. Then, without enter any other text or spaces, select the longer entry "hello world".

ER:
"hello world"

AR:
"hello"

The popup closes, but "hello world" is not inserted in the form. logcat does not show any interesting IME messages, so I suspect the autocomplete text is discarded in Gecko or browser.js before reaching Java.
(Reporter)

Updated

6 years ago
Depends on: 764193
(Reporter)

Comment 1

6 years ago
For autocomplete has been re-enabled in Nightly 17, so this "can't use autocomplete popup twice in a row" bug is reproducible again.
status-firefox17: --- → affected
Priority: -- → P3
Issue is still reproducible on Firefox Mobile 16.0b6 using the Samsung Galaxy R running Android 2.3.4
I cannot reproduce reproduce this issue on the latest Beta, Aurora or Nightly builds. Chris, can you still reproduce this?

--
Firefox 19.0a1 (2012-10-23)
Device: Galaxy S2
OS: Android 4.0.3
status-firefox17: affected → unaffected
status-firefox18: --- → unaffected
status-firefox19: --- → unaffected
Flags: needinfo?(cpeterson)
Version: unspecified → Trunk
However, it still occurs on all branches.
status-firefox17: unaffected → affected
status-firefox18: unaffected → affected
status-firefox19: unaffected → affected
Flags: needinfo?(cpeterson)
(Reporter)

Comment 5

5 years ago
Christian, what IME are you using? With Nightly 19 on my Galaxy Nexus, I can repro with stock VKB, but not Swype VKB.
(In reply to Chris Peterson (:cpeterson) from comment #5)
> Christian, what IME are you using? With Nightly 19 on my Galaxy Nexus, I can
> repro with stock VKB, but not Swype VKB.

I am using the Samsung Keyboard. Now I am able to reproduce this on the latest Nightly.
status-firefox20: --- → affected
status-firefox21: --- → affected
status-firefox22: --- → affected
status-firefox23: --- → affected
status-firefox14: affected → wontfix
status-firefox15: affected → wontfix
status-firefox16: affected → wontfix
status-firefox17: affected → wontfix
status-firefox18: affected → wontfix
status-firefox19: affected → wontfix
I cannot reproduce this issue on Firefox for Aurora 23 or Nightly 24 (2013-05-23 builds). Still affected on Firefox for Android 22 Beta 2.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-firefox23: affected → fixed
status-firefox24: --- → fixed
Resolution: --- → FIXED
Verified fixed on:
Build: Firefox for Android 24.0a1(2013-06-20) and Firefox for Android 23.0a2(2013-06-20)
Device: Samsung Galaxy Nexus
OS: Android 4.1.1
status-firefox23: fixed → verified
status-firefox24: fixed → verified
You need to log in before you can comment on or make changes to this bug.