Last Comment Bug 764046 - Fail configure when --with-system-zlib is used and the system zlib version is too old
: Fail configure when --with-system-zlib is used and the system zlib version is...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla16
Assigned To: Mike Hommey [:glandium]
:
: Gregory Szorc [:gps]
Mentors:
Depends on:
Blocks: 763987
  Show dependency treegraph
 
Reported: 2012-06-12 10:54 PDT by Mike Hommey [:glandium]
Modified: 2012-06-20 08:02 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fail configure when --with-system-zlib/jpeg is used and the system zlib/jpeg version is too old. (2.39 KB, patch)
2012-06-12 11:02 PDT, Mike Hommey [:glandium]
khuey: review+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2012-06-12 10:54:23 PDT
Currently, building with --with-system-zlib (which b2g does) falls back to internal zlib when the system zlib version is too old (or for some reason the version test program fails to compile). It should fail instead of silent fallback.
Comment 1 Mike Hommey [:glandium] 2012-06-12 11:02:46 PDT
Created attachment 632324 [details] [diff] [review]
Fail configure when --with-system-zlib/jpeg is used and the system zlib/jpeg version is too old.

This also disables system zlib on b2g, which it was doing because the AC_TRY_COMPILE test is failing for some reason, while the gzread check passes.
Comment 2 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-06-18 05:37:37 PDT
Comment on attachment 632324 [details] [diff] [review]
Fail configure when --with-system-zlib/jpeg is used and the system zlib/jpeg version is too old.

Review of attachment 632324 [details] [diff] [review]:
-----------------------------------------------------------------

Can we make the error messages print out the version required?

r=me with that

Note You need to log in before you can comment on or make changes to this bug.