Closed Bug 764046 Opened 9 years ago Closed 9 years ago

Fail configure when --with-system-zlib is used and the system zlib version is too old

Categories

(Firefox Build System :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla16

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(1 file)

Currently, building with --with-system-zlib (which b2g does) falls back to internal zlib when the system zlib version is too old (or for some reason the version test program fails to compile). It should fail instead of silent fallback.
This also disables system zlib on b2g, which it was doing because the AC_TRY_COMPILE test is failing for some reason, while the gzread check passes.
Attachment #632324 - Flags: review?(khuey)
Blocks: 763987
Comment on attachment 632324 [details] [diff] [review]
Fail configure when --with-system-zlib/jpeg is used and the system zlib/jpeg version is too old.

Review of attachment 632324 [details] [diff] [review]:
-----------------------------------------------------------------

Can we make the error messages print out the version required?

r=me with that
Attachment #632324 - Flags: review?(khuey) → review+
https://hg.mozilla.org/mozilla-central/rev/df4bbe5ffc47
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.