The default bug view has changed. See this FAQ.

Fail configure when --with-system-zlib is used and the system zlib version is too old

RESOLVED FIXED in mozilla16

Status

()

Core
Build Config
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

unspecified
mozilla16
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Currently, building with --with-system-zlib (which b2g does) falls back to internal zlib when the system zlib version is too old (or for some reason the version test program fails to compile). It should fail instead of silent fallback.
(Assignee)

Comment 1

5 years ago
Created attachment 632324 [details] [diff] [review]
Fail configure when --with-system-zlib/jpeg is used and the system zlib/jpeg version is too old.

This also disables system zlib on b2g, which it was doing because the AC_TRY_COMPILE test is failing for some reason, while the gzread check passes.
Attachment #632324 - Flags: review?(khuey)
(Assignee)

Updated

5 years ago
Blocks: 763987
Comment on attachment 632324 [details] [diff] [review]
Fail configure when --with-system-zlib/jpeg is used and the system zlib/jpeg version is too old.

Review of attachment 632324 [details] [diff] [review]:
-----------------------------------------------------------------

Can we make the error messages print out the version required?

r=me with that
Attachment #632324 - Flags: review?(khuey) → review+
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/df4bbe5ffc47
Target Milestone: --- → mozilla16
https://hg.mozilla.org/mozilla-central/rev/df4bbe5ffc47
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.