Last Comment Bug 764318 - [responsive mode] use this.tab.selected
: [responsive mode] use this.tab.selected
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: Firefox 16
Assigned To: Paul Rouget [:paul]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 03:32 PDT by Paul Rouget [:paul]
Modified: 2012-06-21 01:07 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v1 (949 bytes, patch)
2012-06-13 03:33 PDT, Paul Rouget [:paul]
no flags Details | Diff | Splinter Review
patch v1.1 (2.28 KB, patch)
2012-06-13 04:23 PDT, Paul Rouget [:paul]
no flags Details | Diff | Splinter Review
patch v1.2 (3.02 KB, patch)
2012-06-13 04:35 PDT, Paul Rouget [:paul]
dao+bmo: review+
Details | Diff | Splinter Review
patch v1.3 (3.13 KB, patch)
2012-06-13 05:01 PDT, Paul Rouget [:paul]
dao+bmo: review+
Details | Diff | Splinter Review

Description Paul Rouget [:paul] 2012-06-13 03:32:13 PDT

    
Comment 1 Paul Rouget [:paul] 2012-06-13 03:33:48 PDT
Created attachment 632623 [details] [diff] [review]
patch v1
Comment 2 Paul Rouget [:paul] 2012-06-13 03:35:07 PDT
Dao, I am also interested to know if this is the best way to be notified if a tab has been selected / hidden.
Comment 3 Dão Gottwald [:dao] 2012-06-13 04:13:50 PDT
(In reply to Paul Rouget [:paul] from comment #2)
> Dao, I am also interested to know if this is the best way to be notified if
> a tab has been selected / hidden.

Normally you'd use a TabSelect listener on gBrowser.tabContainer.
Comment 4 Paul Rouget [:paul] 2012-06-13 04:23:30 PDT
Created attachment 632635 [details] [diff] [review]
patch v1.1
Comment 5 Paul Rouget [:paul] 2012-06-13 04:24:28 PDT
Comment on attachment 632635 [details] [diff] [review]
patch v1.1

Thanks.
Comment 6 Dão Gottwald [:dao] 2012-06-13 04:29:45 PDT
When does this event listener get removed?
Comment 7 Paul Rouget [:paul] 2012-06-13 04:35:08 PDT
Created attachment 632637 [details] [diff] [review]
patch v1.2

erf
Comment 8 Paul Rouget [:paul] 2012-06-13 04:52:35 PDT
Actually, this won't work because we uncheck the buttons if another tab is selected.
But we don't know if the next tab is not in the responsive mode.
Comment 9 Paul Rouget [:paul] 2012-06-13 05:01:38 PDT
Created attachment 632643 [details] [diff] [review]
patch v1.3

Uncheck only if the new selected tab is not in responsive mode
Comment 10 Dão Gottwald [:dao] 2012-06-18 07:30:17 PDT
Comment on attachment 632643 [details] [diff] [review]
patch v1.3

Please file a bug on renaming tab.responsiveUI to tab.__responsiveUI, since it's no property managed by tabbrowser.xml but entirely external.
Comment 11 Paul Rouget [:paul] 2012-06-20 03:13:22 PDT
Bug 766512 - Rename tab.responsiveUI to tab.__responsiveUI
Comment 12 Panos Astithas [:past] 2012-06-20 06:52:11 PDT
https://hg.mozilla.org/integration/fx-team/rev/32975daf82d7
Comment 13 Panos Astithas [:past] 2012-06-21 01:07:34 PDT
https://hg.mozilla.org/mozilla-central/rev/32975daf82d7

Note You need to log in before you can comment on or make changes to this bug.