Bad: Mozilla wont start 2 times when Stimon.exe running

RESOLVED DUPLICATE of bug 53952

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 53952
17 years ago
14 years ago

People

(Reporter: Christian Ouellet, Assigned: asa)

Tracking

({relnote})

Trunk
x86
Windows ME
relnote

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.8.1+) Gecko/20010416
BuildID:    2001041604

Still Image Monitor (Stimon.exe) is a tool that is installed by Windows
Millennium Edition (Me) and Windows 98 when a Universal Serial Bus (USB)
scanning device is successfully enumerated. Stimon.exe is configured to start
automatically during the Windows startup process, and is loaded from the
following registry key: 

HKEY_Local_Machine\Software\Microsoft\Windows\Current Version\Run 


It prevent Mozilla from starting.

Reproducible: Always
Steps to Reproduce:
1.have stimon.exe running by having a USB image device installed on the system.
2.start mozilla (fist time willl work)
3.start mozilla again (wont work until you kill stimon.exe and this is not
possible with regular windows ME task manager )

Actual Results:  Mozilla wont start

Expected Results:  Mozilla should start

Only mozilla seems to have problems with stimon.exe. Before I installed my
digital camera I was not having this problem; stimon.exe was probably not runing.

Comment 1

17 years ago
hrm, this would suck.  please grab wintop from microsoft.com, it's a w95 
kerneltoy, please try it and see if it works on winME [specifically, see if you 
can use it to kill stimon, i suspect it won't work since stimon should be 
marked as a kernel process]

wrt finding out where mozilla gets stuck, please follow the instructions at 
http://www.mozilla.org/quality/help/dependency-walker.html
attach the log as a zip file (application/zip)

ideally i'd like to get a DWI file for stimon, but that may not be possible.

Comment 2

17 years ago
I have stimon loaded on my Win98 system, and I've had no problems, so it's 
probably not as simple as just having stimon loaded.  Either that, or it's 
specifically a Windows ME problem that doesn't happen on Win98.
(Reporter)

Comment 3

17 years ago
If I kill stimon.exe with TaskInfo2000(I've grab it from tucows.com) Mozilla 
resume loading.

Comment 4

17 years ago
Possible relnote info.
Severity: blocker → critical
Keywords: relnote

Comment 5

17 years ago
I just tried this on my WinME system.  Stimon wasn't running, as I didn't have
any USB imaging devices installed, but I could start stimon manually.  Used
system info to verify that stimon was loaded, and then started Mozilla.  Loaded
fine.

Whatever the problem is on the reporter's system, stimon may be triggering it,
but I suspect stimon by itself isn't the cause.

Comment 6

17 years ago
almost guarantee you this is a dupe of bug 53952 - Reporter, when you say Moz
won't start, does it in fact load into memory but simply display nothing?
Whiteboard: [dup of 53592?]

Comment 7

17 years ago
based on feedback from the reporter (in Email), this IS indeed a dupe of 53592,
as the symptoms are identical.

*** This bug has been marked as a duplicate of 53592 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Whiteboard: [dup of 53592?]
fixing Typo in bug #
(reopening)
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
duping to the correct bug

*** This bug has been marked as a duplicate of 53952 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.