Last Comment Bug 764324 - Fix breakpoint handling for Fennec and B2G browser actors
: Fix breakpoint handling for Fennec and B2G browser actors
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: Trunk
: All All
: P2 normal (vote)
: Firefox 16
Assigned To: Panos Astithas [:past] (away until 7/21)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 03:54 PDT by Panos Astithas [:past] (away until 7/21)
Modified: 2012-06-20 06:10 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Combined patch (3.47 KB, patch)
2012-06-13 03:58 PDT, Panos Astithas [:past] (away until 7/21)
21: review+
mark.finkle: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Panos Astithas [:past] (away until 7/21) 2012-06-13 03:54:07 PDT
Bug 737808 changed the way breakpoints are handled in the debugger server, but only desktop Firefox was updated. Fennec and B2G need the same changes in order for breakpoint setting to work. Bug 751226 will make sure we never get into this situation again, but it may be a few more weeks until I can get to it.
Comment 1 Panos Astithas [:past] (away until 7/21) 2012-06-13 03:58:13 PDT
Created attachment 632629 [details] [diff] [review]
Combined patch

Simple fix. B2G needed an additional fix for including the XPCOM helper in the packaging, in order for the debugger to work in a real device (as opposed to desktop b2g).
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2012-06-13 06:55:59 PDT
Comment on attachment 632629 [details] [diff] [review]
Combined patch

r+ on the fennec parts
Comment 3 Panos Astithas [:past] (away until 7/21) 2012-06-15 02:10:43 PDT
https://hg.mozilla.org/integration/fx-team/rev/864c3502d038
Comment 4 Tim Taubert [:ttaubert] 2012-06-16 03:44:50 PDT
https://hg.mozilla.org/mozilla-central/rev/864c3502d038
Comment 5 Panos Astithas [:past] (away until 7/21) 2012-06-18 10:04:45 PDT
Comment on attachment 632629 [details] [diff] [review]
Combined patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New feature
User impact if declined: Fennec 15 will have broken breakpoint support in the debugger
Testing completed (on m-c, etc.): On m-c
Risk to taking this patch (and alternatives if risky): this is a pretty straight-forward patch that only adds two new single-line methods. There is the same change for b2g as well which does not impact Fennec in any way, which could be left out if people are worried for some reason.
String or UUID changes made by this patch: none
Comment 6 Alex Keybl [:akeybl] 2012-06-19 19:42:44 PDT
Comment on attachment 632629 [details] [diff] [review]
Combined patch

[Triage Comment]
Fix for a new feature, risk to b2g but we're not shipping b2g off of 15 so go for it.
Comment 7 Panos Astithas [:past] (away until 7/21) 2012-06-20 06:10:58 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/d41b2d8f0630

Note You need to log in before you can comment on or make changes to this bug.