crash [@ TouchBadMemory | mozalloc_abort | nsHttpResponseHead::MustValidate ]

RESOLVED DUPLICATE of bug 746730

Status

()

Firefox for Android
General
--
critical
RESOLVED DUPLICATE of bug 746730
6 years ago
6 years ago

People

(Reporter: xti, Unassigned)

Tracking

({crash, reproducible})

14 Branch
ARM
Android
crash, reproducible
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

6 years ago
This bug was filed from the Socorro interface and is 
report bp-cbe17ef7-4430-4ddd-ad4a-d087a2120613 .
============================================================= 

Frame 	Module 	Signature 	Source
0 	libmozalloc.so 	TouchBadMemory 	memory/mozalloc/mozalloc_abort.cpp:68
1 	libmozalloc.so 	mozalloc_abort 	memory/mozalloc/mozalloc_abort.cpp:89
2 	dalvik-heap (deleted) 	dalvik-heap @0x7aa11f 	
3 	dalvik-mark-stack (deleted) 	dalvik-mark-stack @0x31a8f40 	
4 	libxul.so 	nsHttpResponseHead::MustValidate 	netwerk/protocol/http/nsHttpResponseHead.h:72
5 		@0x656c706b 	
6 	dalvik-heap (deleted) 	dalvik-heap @0xe9cc66b 	
7 	dalvik-mark-stack (deleted) 	dalvik-mark-stack @0x32db273 	
8 	dalvik-mark-stack (deleted) 	dalvik-mark-stack @0x129602a 	
9 	org.mozilla.firefox_beta-1.apk 	org.mozilla.firefox_beta-1.apk@0xff2063 	
10 	org.mozilla.firefox_beta-1.apk 	org.mozilla.firefox_beta-1.apk@0x1d7263 	
11 	dalvik-heap (deleted) 	dalvik-heap @0xba1cf70 	
12 	libxul.so 	nsACString_internal::AppendFunc 	nsTSubstring.h:388
13 	libnspr4.so 	FuncStuff 	nsprpub/pr/src/io/prprf.c:1075
14 	libnspr4.so 	fill_n 	nsprpub/pr/src/io/prprf.c:237
15 		@0x63 	
16 	libxul.so 	nsACString_internal::ReplaceASCII 	xpcom/string/src/nsTSubstring.cpp:503
17 	libxul.so 	nsACString_internal::AppendFunc 	nsTSubstring.h:388
18 	libnspr4.so 	FuncStuff 	nsprpub/pr/src/io/prprf.c:1075
19 	libnspr4.so 	dosprintf 	nsprpub/pr/src/io/prprf.c:1060
20 	libnspr4.so 	PR_vsxprintf 	nsprpub/pr/src/io/prprf.c:1105
21 		@0x63ad26de 	
22 	app_process 	app_process@0xcd4 	
23 	libxul.so 	mozilla::layers::LayerManagerOGL::CreateFBOWithTexture 	gfx/layers/opengl/LayerManagerOGL.cpp:1251
24 	libxul.so 	mozilla::layers::ShadowContainerLayerOGL::RenderLayer 	gfx/layers/opengl/ContainerLayerOGL.cpp:215
25 	libxul.so 	mozilla::layers::ShadowContainerLayerOGL::RenderLayer 	gfx/layers/opengl/ContainerLayerOGL.cpp:252
26 	libxul.so 	mozilla::layers::ShadowContainerLayerOGL::RenderLayer 	gfx/layers/opengl/ContainerLayerOGL.cpp:252
27 	libxul.so 	mozilla::layers::ShadowContainerLayerOGL::RenderLayer 	gfx/layers/opengl/ContainerLayerOGL.cpp:252
28 	libxul.so 	mozilla::layers::LayerManagerOGL::Render 	gfx/layers/opengl/LayerManagerOGL.cpp:833
29 	libxul.so 	mozilla::layers::LayerManagerOGL::EndTransaction 	gfx/layers/opengl/LayerManagerOGL.cpp:468
30 	libxul.so 	mozilla::layers::LayerManagerOGL::EndEmptyTransaction 	gfx/layers/opengl/LayerManagerOGL.cpp:441
31 	libxul.so 	mozilla::layers::CompositorParent::Composite 	gfx/layers/ipc/CompositorParent.cpp:259
32 	libxul.so 	RunnableMethod<mozilla::layers::CompositorParent, void , Tuple0>::Run 	ipc/chromium/src/base/tuple.h:383
33 	libxul.so 	MessageLoop::RunTask 	ipc/chromium/src/base/message_loop.cc:318
34 	libxul.so 	MessageLoop::DeferOrRunPendingTask 	ipc/chromium/src/base/message_loop.cc:326
35 	libxul.so 	MessageLoop::DoWork 	ipc/chromium/src/base/message_loop.cc:426
36 	libxul.so 	base::MessagePumpDefault::Run 	ipc/chromium/src/base/message_pump_default.cc:23
37 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:208
38 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:201
39 	libxul.so 	base::Thread::ThreadMain 	ipc/chromium/src/base/thread.cc:156
40 	libxul.so 	ThreadFunc 	ipc/chromium/src/base/platform_thread_posix.cc:26
41 	libc.so 	libc.so@0x12c1e 	
42 	libc.so 	libc.so@0x12772


Note: There are the same STR as in Bug 764392

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 746730
You need to log in before you can comment on or make changes to this bug.