Last Comment Bug 764474 - [inspector] arrow keys are creating problems
: [inspector] arrow keys are creating problems
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Inspector (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: Firefox 16
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 10:28 PDT by Paul Rouget [:paul]
Modified: 2012-07-10 02:07 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (3.03 KB, patch)
2012-07-03 05:20 PDT, Paul Rouget [:paul]
fayearthur: review+
Details | Diff | Review

Description Paul Rouget [:paul] 2012-06-13 10:28:27 PDT
The highlighter highlights other elements when we use the arrow keys.
But we don't stop the event.

If the web site uses the arrows keys to do "things", it's just a complete mess.
Use right/left with this website for example: http://www.tibco.com/
Or try to move the cursor in jsbin.com.

I think we should just not highlight other nodes when arrow keys are pressed.
Comment 1 Paul Rouget [:paul] 2012-06-13 11:02:33 PDT
We should only use the arrow keys when the breadcrumbs are focused.
Comment 2 Paul Rouget [:paul] 2012-07-03 05:20:55 PDT
Created attachment 638660 [details] [diff] [review]
v1
Comment 3 Heather Arthur [:harth] 2012-07-05 12:30:45 PDT
Comment on attachment 638660 [details] [diff] [review]
v1

Really into this patch, much better behavior now. I guess you could change that comment since it's a one-item list now, but not necessary at all. Awesome!
Comment 4 Paul Rouget [:paul] 2012-07-09 06:49:46 PDT
https://hg.mozilla.org/integration/fx-team/rev/7ca8c657adae
Comment 5 Tim Taubert [:ttaubert] 2012-07-10 02:07:31 PDT
https://hg.mozilla.org/mozilla-central/rev/7ca8c657adae

Note You need to log in before you can comment on or make changes to this bug.