If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Fennec Native Go Live: Be sure blocked devices are properly filtered (minimum system requirements, 7" tablets)

RESOLVED FIXED

Status

()

Firefox for Android
General
P1
normal
RESOLVED FIXED
5 years ago
a year ago

People

(Reporter: elan, Assigned: elan)

Tracking

14 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox14 fixed, blocking-fennec1.0 +)

Details

(Whiteboard: [no-code])

Attachments

(3 attachments)

(Assignee)

Description

5 years ago
Step 0: Alex to give Erin list of blocked devices

Step 1: Erin to cross-reference PDADB to get models and serial numbers for blocked devices

Step 2: Provide this data Aki to implement

Step 3: QA to spot check
(Assignee)

Updated

5 years ago
blocking-fennec1.0: --- → +
Whiteboard: [no code]
(Assignee)

Updated

5 years ago
Summary: Fennec Native Go Live: Be sure that all intended devices are properly filtered → Fennec Native Go Live: Be sure blocked devices are properly filtered
(Assignee)

Updated

5 years ago
Whiteboard: [no code] → [no-code]

Comment 1

5 years ago
(In reply to Erin Lancaster from comment #0)
> Step 0: Alex to give Erin list of blocked devices

No devices are blocked currently. I've included kbrosnan here to see if that matches his expectations. The only bug for blocking devices that I could find (other than the mass tablet block) was bug 755073, which was temporary.

> Step 1: Erin to cross-reference PDADB to get models and serial numbers for
> blocked devices

I'm including the list of devices that aren't already blocked by our minimum Android version requirements, and aren't already known tablets. There are 733 in total. If we don't think it's feasible to find each and make sure they meet our system requirements, we should probably work in the opposite direction and cover the most popular unsupported phones.

Next step is to cull down this text file to those phones that need to be blocked based upon CPU speed and RAM.

Comment 2

5 years ago
Created attachment 633003 [details]
All phones on Google Play (and maybe some errant tablets)

Comment 3

5 years ago
Let me know if / when you need me to categorize the devices by popularity.

Updated

5 years ago
Assignee: nobody → elancaster

Comment 4

5 years ago
Lets get the Motorola Atrix 4G on your radar.  bug 765150 needs more testing, and so far its only been seen on this device.   But not having the ability to play video in html5, especially since we already block flash on it, may rally up more complaints.

Tony
(Assignee)

Comment 5

5 years ago
Alex, thx for the phone list. ETA for cull based on CPU and RAM is by triage tuesday, 5/18.
(Assignee)

Comment 6

5 years ago
Adding Motorola Atrix 4G and Motorola Photon to possible list (issues with each may be different bugs.
(Assignee)

Comment 7

5 years ago
Need to cross reference with mluna's list of phones she has reports of issues with.

Updated

5 years ago
Summary: Fennec Native Go Live: Be sure blocked devices are properly filtered → Fennec Native Go Live: Be sure blocked devices are properly filtered (minimum system requirements, 7" tablets)

Comment 9

5 years ago
This bug needs to include 7" tablets (since we just confirmed they're not covered by bug 760740). I think we should use the Android device database that Irina uses to find a list of devices that need to be blocked.

Remaining work in this bug:

* Find all phones in the attachment that don't meet our minimum system requirements
* Find all 7" tablets using the database, and list them
* Manually block anything in the above lists on the Google Play store prior to launch (step 2)
* Verification (step 3)

Comment 11

5 years ago
Here is the list of Android tablets with 7 inch screens: http://bit.ly/NTs98B

Do you mean only 7 inch ones or also potentially 7.2 or 7.3?
(In reply to Irina Sandu from comment #11)
> Here is the list of Android tablets with 7 inch screens: http://bit.ly/NTs98B
> 
> Do you mean only 7 inch ones or also potentially 7.2 or 7.3?

I think the real ask is >=7in and <9in (which is already properly blocked).

Comment 13

5 years ago
Then the list has a few additional devices: http://bit.ly/KADo3w
I've just blocked all the 7" tablets I could find for beta. I'll attach the list of 7-9" tablets that were already excluded, that I couldn't find, and that I blocked (to do the same at release).
Created attachment 635445 [details]
The small tablets I just blocked (needed for release)
(Assignee)

Comment 16

5 years ago
Here is the list of phones = https://etherpad.mozilla.org/phonestatus
Bold = Block
√ = Don't Block
Sections marked with <beta_blocks_complete> have now been blocked on the beta product.
(Assignee)

Comment 18

5 years ago
\o/ Cross-reference task is complete. Thank you everyone!
Created attachment 636369 [details]
Final blocks on both release and beta
I've just blocked the above list of unsupported phones and 7" tablets on Google Play for both the beta and release products.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
status-firefox14: --- → fixed
Why was the Droid X2 black listed? It meets the minimum requirements and we decided not to black list for the purple video bug.
(Assignee)

Comment 22

5 years ago
(sorry, Alex is unblocking)
On that note, Atrix too?
(Assignee)

Comment 24

5 years ago
just to follow up from IRC, no. :)
Depends on: 768586
Dell Streak(streak) should be un-blocked (bug 768586).

Dell Streak 7(streak7) should remain blocked, because it is a 7" Honeycomb tablet.
You need to log in before you can comment on or make changes to this bug.