Last Comment Bug 764545 - WebConsole default position should be "below"
: WebConsole default position should be "below"
Status: RESOLVED FIXED
[fixed-in-fx-team][good first bug][me...
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Console (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: Firefox 16
Assigned To: Sankha Narayan Guria [:sankha]
:
Mentors:
Depends on: 785433
Blocks: 745773
  Show dependency treegraph
 
Reported: 2012-06-13 13:25 PDT by Paul Rouget [:paul]
Modified: 2012-08-24 10:20 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch to the bug; needs review (1.17 KB, patch)
2012-06-26 01:48 PDT, Sankha Narayan Guria [:sankha]
no flags Details | Diff | Splinter Review
[in-fx-team] Patch now passes all webconsole tests (5.65 KB, patch)
2012-06-26 23:57 PDT, Sankha Narayan Guria [:sankha]
mihai.sucan: review+
Details | Diff | Splinter Review

Description Paul Rouget [:paul] 2012-06-13 13:25:16 PDT
When we will enable the global developer toolbar, we want the console to show up above the toolbar.
Comment 1 Josh Matthews [:jdm] (away until 9/3) 2012-06-25 15:16:54 PDT
Link to relevant source?
Comment 2 Paul Rouget [:paul] 2012-06-25 15:22:07 PDT
I think we only need to update this value:
http://mxr.mozilla.org/mozilla-central/source/browser/app/profile/firefox.js#1097
Comment 3 Sankha Narayan Guria [:sankha] 2012-06-25 22:33:47 PDT
I have a patch ready for this bug. But who should I ask for review when posting the patch?
Comment 4 Mihai Sucan [:msucan] 2012-06-26 01:34:18 PDT
Sankha: you can ask me for review. Thanks for your time working on this bug!
Comment 5 Sankha Narayan Guria [:sankha] 2012-06-26 01:48:17 PDT
Created attachment 636628 [details] [diff] [review]
Patch to the bug; needs review
Comment 6 Mihai Sucan [:msucan] 2012-06-26 02:08:14 PDT
Comment on attachment 636628 [details] [diff] [review]
Patch to the bug; needs review

Thanks for your patch! It applies cleanly and it does what we want.

However, we have a couple of tests that fail now because they expect the other position. Can you please run the tests and fix the failures?

See https://developer.mozilla.org/en/Browser_chrome_tests

The Web Console tests are located in browser/devtools/webconsole/test. Please let me know if I can help.

Thanks!
Comment 7 Sankha Narayan Guria [:sankha] 2012-06-26 23:57:37 PDT
Created attachment 637013 [details] [diff] [review]
[in-fx-team] Patch now passes all webconsole tests
Comment 8 Mihai Sucan [:msucan] 2012-06-27 03:53:56 PDT
Comment on attachment 637013 [details] [diff] [review]
[in-fx-team] Patch now passes all webconsole tests

Thank you for a patch well done!

I pushed the patch to the try servers to make sure all tests pass on all systems, not just mine and yours.

https://tbpl.mozilla.org/?tree=Try&rev=805149a6e4b7

Once results are positive, we will push your patch into Firefox. Thanks!
Comment 9 Mihai Sucan [:msucan] 2012-06-28 04:12:42 PDT
Comment on attachment 637013 [details] [diff] [review]
[in-fx-team] Patch now passes all webconsole tests

Landed:
https://hg.mozilla.org/integration/fx-team/rev/afc76272017b

Thank you for your contribution Sankha!
Comment 10 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2012-06-30 15:16:36 PDT
https://hg.mozilla.org/mozilla-central/rev/afc76272017b

Note You need to log in before you can comment on or make changes to this bug.