Last Comment Bug 764667 - Implement ContactChangeEvent in C++
: Implement ContactChangeEvent in C++
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla16
Assigned To: Gregor Wagner [:gwagner]
:
Mentors:
Depends on: 765136
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-13 17:45 PDT by Gregor Wagner [:gwagner]
Modified: 2012-06-15 07:13 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (19.22 KB, patch)
2012-06-13 18:51 PDT, Gregor Wagner [:gwagner]
bugs: review+
Details | Diff | Review

Description Gregor Wagner [:gwagner] 2012-06-13 17:45:40 PDT

    
Comment 1 Gregor Wagner [:gwagner] 2012-06-13 18:51:57 PDT
Created attachment 632991 [details] [diff] [review]
patch

Followed the settings implementation.
Comment 2 Olli Pettay [:smaug] 2012-06-14 04:23:54 PDT
Comment on attachment 632991 [details] [diff] [review]
patch

>--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
>+++ b/content/events/src/nsDOMContactChangeEvent.cpp	Wed Jun 13 18:51:19 2012 -0700
>@@ -0,0 +1,67 @@
>+/* -*- Mode: C++; tab-width: 2; indent-tabs-mode: nil; c-basic-offset: 2 -*- */
>+/* This Source Code Form is subject to the terms of the Mozilla Public
>+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
>+ * You can obtain one at http://mozilla.org/MPL/2.0/. */
>+
>+#include "nsDOMContactChangeEvent.h"
>+#include "nsContentUtils.h"
>+#include "DictionaryHelpers.h"
>+
>+DOMCI_DATA(MozContactChangeEvent, nsDOMMozContactChangeEvent)
>+
>+NS_INTERFACE_MAP_BEGIN(nsDOMMozContactChangeEvent)
>+  NS_INTERFACE_MAP_ENTRY(nsIDOMMozContactChangeEvent)
>+  NS_DOM_INTERFACE_MAP_ENTRY_CLASSINFO(MozContactChangeEvent)
>+NS_INTERFACE_MAP_END_INHERITING(nsDOMEvent)
>+
>+NS_IMPL_ADDREF_INHERITED(nsDOMMozContactChangeEvent, nsDOMEvent)
>+NS_IMPL_RELEASE_INHERITED(nsDOMMozContactChangeEvent, nsDOMEvent)
>+
>+NS_IMETHODIMP
>+nsDOMMozContactChangeEvent::GetContactID(nsAString & aContactID)
nsAString& aContactID


>+nsDOMMozContactChangeEvent::GetReason(nsAString & aReason)
nsAString& aReason



>+nsDOMMozContactChangeEvent::InitMozContactChangeEvent(const nsAString& aType,
>+                                                      bool aCanBubble,
>+                                                      bool aCancelable,
>+                                                      const nsAString &aContactID,
>+                                                      const nsAString &aReason)
const nsAString& aContactID,
const nsAString& aReason



>+class nsDOMMozContactChangeEvent : public nsDOMEvent,
>+                                   public nsIDOMMozContactChangeEvent
>+{
>+public:
>+  nsDOMMozContactChangeEvent(nsPresContext* aPresContext, nsEvent* aEvent)
>+    : nsDOMEvent(aPresContext, aEvent) {}
>+                     
>+  NS_DECL_ISUPPORTS_INHERITED
>+  NS_DECL_CYCLE_COLLECTION_CLASS_INHERITED(nsDOMMozContactChangeEvent, nsDOMEvent)
There shouldn't be need for this. You're not adding anything to the cycle collection.



> 
> [scriptable, builtinclass, uuid(50e09826-d08e-4a75-8efb-5dfb2aa70874)]
>-interface mozIDOMContactEvent : nsIDOMEvent
>+interface nsIDOMMozContactChangeEvent : nsIDOMEvent
update the uuid
Comment 4 Ed Morley [:emorley] 2012-06-15 05:58:26 PDT
Android M3 is pretty much perma-orange due to bug 765136.
Do you have a rough timeframe for when you'll be able to look at that failure, so we know whether to back this out or hold off?

Thanks :-)
Comment 5 Ed Morley [:emorley] 2012-06-15 05:59:45 PDT
https://hg.mozilla.org/mozilla-central/rev/5a0a22492be2
Comment 6 Gregor Wagner [:gwagner] 2012-06-15 07:00:32 PDT
(In reply to Ed Morley [:edmorley] from comment #4)
> Android M3 is pretty much perma-orange due to bug 765136.
> Do you have a rough timeframe for when you'll be able to look at that
> failure, so we know whether to back this out or hold off?
> 
> Thanks :-)

Huh sorry about that. I would say lets disable the test and I will look into it  today. Backing out means event handling in B2G is broken so it's not much better. We only use the contacts event feature in B2G.
Comment 7 Ed Morley [:emorley] 2012-06-15 07:13:18 PDT
(In reply to Gregor Wagner [:gwagner] from comment #6)
> Huh sorry about that. I would say lets disable the test and I will look into
> it  today.

That sounds good to me - would you be ok sorting that for me whilst I file the bazillion (unrelated) other new oranges? :-)

Note You need to log in before you can comment on or make changes to this bug.