If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

First-run/upgrade tutorial to introduce new features to users

RESOLVED DUPLICATE of bug 862998

Status

()

Firefox
Untriaged
--
enhancement
RESOLVED DUPLICATE of bug 862998
5 years ago
4 years ago

People

(Reporter: tomer, Unassigned)

Tracking

13 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
The last week and half was very traumatic to some users, with the roll-out of a major upgrade introducing some UI changes that some users don't like (imagine the privacy impact of having their most-viewed sites appearing in the family computer each time they open a new tab…☺) and others who find it difficult to set up or to disable. 

Right after the roll-out of the Firefox 13 update, users were starting to complain and ask questions about the new tab page. The negative impact was so big that I sat down and wrote a blog post in my language to better introduce users to these features and provide them the most relevant information and how to disable these features. You see, users won't always find us to complain, and such features can trigger angry users to switch browsers. We have the whatsnew page, but I understood that users are skipping this. 


My suggestion is to add short tutorial to major UI changes such the addition on about:newtab and about:home overall, that will provide users short introduction to these features. My idea came from WordPress installation, that show some tooltip introduction after upgrade to show the users the new features on the first time they actually see the feature in action. 

Next, this quick introduction feature can also be used as a guided tour to new users – when they open a new browser profile, we can show them some tips and tricks we find important that could be helpful to them and will help them to get the most from Firefox. I imagine that such tutorial could be very helpful to my parents and I won't get emergency phone calls from my family each time they spot some UI changes.

Comment 1

5 years ago
Google show tooltips for new features:
http://techhamlet.com/wp-content/uploads/2010/08/gmail-new-look.jpg
Looks like this is happening as part of the rollout of the new "Australis" default theme (bug 862998).
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 862998
You need to log in before you can comment on or make changes to this bug.