Last Comment Bug 764752 - gfxAndroidPlatform::Optimal2DFormatForContent assumes Android only
: gfxAndroidPlatform::Optimal2DFormatForContent assumes Android only
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: All Gonk (Firefox OS)
: -- normal (vote)
: mozilla16
Assigned To: Kan-Ru Chen [:kanru] (UTC+8)
:
:
Mentors:
Depends on: 743182
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-14 03:16 PDT by Michael Wu [:mwu]
Modified: 2012-06-20 08:02 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Choose optimal 2D format based on off-screen format. (3.38 KB, patch)
2012-06-14 23:01 PDT, Kan-Ru Chen [:kanru] (UTC+8)
joe: review+
Details | Diff | Splinter Review

Description Michael Wu [:mwu] 2012-06-14 03:16:46 PDT
gfxAndroidPlatform is also used on gonk so we should return 16 or 24 bit depending on whether the device supports it.
Comment 1 Kan-Ru Chen [:kanru] (UTC+8) 2012-06-14 23:01:48 PDT
Created attachment 633406 [details] [diff] [review]
Choose optimal 2D format based on off-screen format.

Removed the specialized case for Android since screen->GetColorDepth(&mScreenDepth); already return 16bpp for Android.
Comment 2 Joe Drew (not getting mail) 2012-06-19 15:26:27 PDT
Comment on attachment 633406 [details] [diff] [review]
Choose optimal 2D format based on off-screen format.

Review of attachment 633406 [details] [diff] [review]:
-----------------------------------------------------------------

Lovely. Sorry it took me a little while to review.
Comment 3 Kan-Ru Chen [:kanru] (UTC+8) 2012-06-19 21:06:41 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/e022416669a1

Note You need to log in before you can comment on or make changes to this bug.