Closed Bug 764756 Opened 8 years ago Closed 7 years ago

[skiplist] Fix Android library ignore skiplist referring to fennec or wrong

Categories

(Socorro :: Backend, task)

task
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: scoobidiver, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [qa-])

Replace:
* 'data@app@org\.mozilla\.fennec-\d\.apk@classes\.dex@0x.*' by 'data@app@org\.mozilla\.f.*-\d\.*.apk@classes\.dex@0x.*'
* 'mnt@asec@org\.mozilla\.fennec-\d@pkg\.apk@classes\.dex@0x.*' by 'mnt@asec@org\.mozilla\.f.*-\d@pkg\.apk@classes\.dex@0x.*'
* 'org\.mozilla\.fennec-\d\.apk@0x.*' by 'org\.mozilla\.f.*-\d\.apk@0x.*'
* 'system@framework@*\.jar@classes\.dex@0x.*' by 'system@framework@.*\.jar@classes\.dex@0x.*'
Blocks: 749687
Blocks: 763805
Blocks: 751977
Blocks: 774622
Blocks: 705641
Blocks: 780831
Blocks: 825996
Blocks: 787017
Blocks: 846319
Blocks: 846649
Blocks: 890590
> * 'data@app@org\.mozilla\.fennec-\d\.apk@classes\.dex@0x.*' by 'data@app@org\.mozilla\.f.*-\d\.*.apk@classes\.dex@0x.*'

this substitution looks suspicious.  Please verify the replacement in this fragment:

    \d\.*.apk@

a digit followed by zero or more dots followed by any single character then "apk@" ?
Component: Infra → Backend
Target Milestone: --- → 54
It is suspicious, yes. Please don't add the additional "*." there for now, and let's let Scoobidiver clear that one up if needed.
The "f.*" change makes sense without any other there as well.
I'm going forward with this:

'data@app@org\.mozilla\.f.*-\d\.apk@classes\.dex@0x.*'

see PR 1338 (https://github.com/mozilla/socorro/pull/1338) for the actual change in situ.
(In reply to K Lars Lohn [:lars] [:klohn] from comment #3)
> I'm going forward with this:
> 'data@app@org\.mozilla\.f.*-\d\.apk@classes\.dex@0x.*'
It was intended to skip signatures like in bp-a3f56ebe-c3dd-49a9-be32-7cec32130716. You guessed right.
Commit pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/160daad7edd448bdc8912dddc54aed380cf7bafd
Merge pull request #1338 from twobraids/skiplist-20130716

fixes Bug 764756, fixes Bug 878414, fixes Bug 885443 - skiplist changes
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.