Last Comment Bug 764817 - Changing input.value during a touchstart event has bizarre results
: Changing input.value during a touchstart event has bizarre results
Status: RESOLVED WORKSFORME
:
Product: Firefox for Android
Classification: Client Software
Component: Keyboards and IME (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-14 07:29 PDT by Atul Varma [:atul]
Modified: 2014-12-11 15:19 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Test case (1.20 KB, text/html)
2012-06-14 07:32 PDT, Atul Varma [:atul]
no flags Details
Fixed test case (1.20 KB, text/html)
2012-06-14 07:36 PDT, Atul Varma [:atul]
no flags Details

Description Atul Varma [:atul] 2012-06-14 07:29:21 PDT
I'm not sure what's going on here, but I've generated a test case and will upload it shortly.
Comment 1 Atul Varma [:atul] 2012-06-14 07:32:20 PDT
Created attachment 633130 [details]
Test case
Comment 2 Atul Varma [:atul] 2012-06-14 07:36:24 PDT
Created attachment 633132 [details]
Fixed test case
Comment 3 Atul Varma [:atul] 2012-06-14 07:42:31 PDT
Steps to reproduce:

1. In Fennec Native, visit https://bug764817.bugzilla.mozilla.org/attachment.cgi?id=633132.
2. Type 'h' into the text field.
3. Tap the 'add letter a' button. The expected new value of the text field is 'ha', while the actual value is 'a'.

You can also try this out in Mobile Safari, Mobile Chrome Beta, and the stock Android browser; all of them exhibit the expected behavior.
Comment 4 Martijn Wargers [:mwargers] (not working for Mozilla) 2012-06-14 07:59:06 PDT
I think this is ime related.
I can reproduce this on the Galaxy Nexus, it underlines the 'h', which means some ime thing is going on.
I can't reproduce it on the Galaxy SII, which doesn't do that ime thing.
Comment 5 Kevin Brosnan [:kbrosnan] 2014-12-11 15:19:07 PST
This works for me using Firefox 37.

Note You need to log in before you can comment on or make changes to this bug.