The default bug view has changed. See this FAQ.

Animating the width/height of an outer SVG element doesn't work

VERIFIED FIXED in Firefox 14

Status

()

Core
SVG
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Robert Longson, Assigned: Robert Longson)

Tracking

({regression})

Trunk
mozilla16
regression
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox13 affected, firefox14 verified, firefox15 verified)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

Comment hidden (empty)
(Assignee)

Comment 1

5 years ago
Worked in Firefox 8 doesn't work from 12 onwards.

Another example is: http://hoffmann.bplaced.net/svgtest/widthheight02.svg
OS: Windows 7 → All
Hardware: x86_64 → All
(Assignee)

Updated

5 years ago
Keywords: regression
(Assignee)

Comment 2

5 years ago
regression range:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6f4f2e53694b&tochange=b87861e50640
Blocks: 668163
(Assignee)

Comment 3

5 years ago
Created attachment 633551 [details] [diff] [review]
patch
Assignee: nobody → longsonr
Attachment #633551 - Flags: review?(jwatt)
(Assignee)

Updated

5 years ago
status-firefox13: --- → affected
status-firefox14: --- → affected
status-firefox15: --- → affected
status-firefox16: --- → affected
Comment on attachment 633551 [details] [diff] [review]
patch

Please add a comment along the lines of the following at the start of nsSVGElement::GetAnimatedAttr:

  // We check mapped-into-style attributes first so that animations
  // targeting width/height on outer-<svg> don't appear to be ignored
  // because we returned a nsISMILAttr for the corresponding
  // SVGAnimatedLength.
Attachment #633551 - Flags: review?(jwatt) → review+
(Assignee)

Comment 5

5 years ago
Created attachment 633795 [details] [diff] [review]
updated with comments and extra tweak to pass try
Attachment #633551 - Attachment is obsolete: true
(Assignee)

Comment 6

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/1a625cb42f58
Flags: in-testsuite+
Target Milestone: --- → mozilla16
(Assignee)

Updated

5 years ago
Blocks: 688430
https://hg.mozilla.org/mozilla-central/rev/1a625cb42f58
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

5 years ago
Comment on attachment 633795 [details] [diff] [review]
updated with comments and extra tweak to pass try

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 668163
User impact if declined: width/height animations on outer svg won't work.
Testing completed (on m-c, etc.): passed tests on m-c, new tests added
Risk to taking this patch (and alternatives if risky): very low
String or UUID changes made by this patch: none
Attachment #633795 - Flags: approval-mozilla-beta?
Attachment #633795 - Flags: approval-mozilla-aurora?

Updated

5 years ago
status-firefox16: affected → ---

Comment 9

5 years ago
Comment on attachment 633795 [details] [diff] [review]
updated with comments and extra tweak to pass try

[Triage Comment]
Fairly recent, low risk SVG regression. Approving for Aurora/Beta.
Attachment #633795 - Flags: approval-mozilla-beta?
Attachment #633795 - Flags: approval-mozilla-beta+
Attachment #633795 - Flags: approval-mozilla-aurora?
Attachment #633795 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/9d7c2b626f17
https://hg.mozilla.org/releases/mozilla-beta/rev/bc003244b5c9
status-firefox14: affected → fixed
status-firefox15: affected → fixed
Verified fixed on FF 14b9 on Win 7, Ubuntu 12.04 and Mac OS X 10.6.
status-firefox14: fixed → verified
Verified fixed on FF 15b3 on Win 7, Ubuntu 12.04 and Mac OS X 10.6.
Status: RESOLVED → VERIFIED
status-firefox15: fixed → verified
You need to log in before you can comment on or make changes to this bug.