Closed Bug 765111 Opened 12 years ago Closed 9 years ago

Crash with canvas2d.createPattern(webgl)

Categories

(Core :: Graphics: Canvas2D, defect)

x86_64
macOS
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jruderman, Assigned: jrmuizel)

References

Details

(Keywords: crash, testcase, Whiteboard: [fuzzblocker])

Crash Data

Attachments

(2 files)

Crash [@ mozilla::gfx::GetImageFromSourceSurface ]
Crash Signature: [@ mozilla::gfx::GetImageFromSourceSurface ] → [@ mozilla::gfx::GetImageFromSourceSurface ] [@ mozilla::gfx::CreateCGPattern ]
Can't reproduce the crash here, but the stack trace is definitely canvas2d not WebGL.
Component: Canvas: WebGL → Canvas: 2D
Hmm, it crashes reliably for me on Mac.
Summary: Crash with createPattern(canvas3d) → Crash with createPattern(canvas2d)
DrawTargetCG!
Assignee: nobody → jmuizelaar
Summary: Crash with createPattern(canvas2d) → Crash with canvas2d.createPattern(canvas3d)
Jesse, "canvas3d" was renamed to "WebGL" a few years ago ;-)
Also, I /can/ reproduce here with Linux 64bit, default config (using Cairo, non-Azure canvas)
Summary: Crash with canvas2d.createPattern(canvas3d) → Crash with canvas2d.createPattern(webgl)
A lot of other bugs are incorrectly being ignored due to this one :(
Whiteboard: [fuzzblocker]
Can't reproduce on Linux 64 with a recently nightly.
WFM with mozilla-central on Mac 10.11.1, even if I try to emulate old settings with:

  user_pref("gfx.canvas.azure.backends", "cg");
Status: NEW → RESOLVED
Closed: 9 years ago
Flags: in-testsuite?
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: