Last Comment Bug 765116 - mozglue/android: fix gcc -Wall -pedantic warnings
: mozglue/android: fix gcc -Wall -pedantic warnings
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: Trunk
: ARM Android
: -- minor (vote)
: Firefox 16
Assigned To: Chris Peterson [:cpeterson]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-14 19:03 PDT by Chris Peterson [:cpeterson]
Modified: 2012-06-19 01:20 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
part-1-fix-Wall-warnings.patch (2.68 KB, patch)
2012-06-14 19:06 PDT, Chris Peterson [:cpeterson]
mh+mozilla: review+
Details | Diff | Splinter Review
part-2-fix-pedantic-warnings.patch (6.80 KB, patch)
2012-06-14 19:11 PDT, Chris Peterson [:cpeterson]
mh+mozilla: review+
Details | Diff | Splinter Review

Description Chris Peterson [:cpeterson] 2012-06-14 19:03:12 PDT

    
Comment 1 Chris Peterson [:cpeterson] 2012-06-14 19:06:34 PDT
Created attachment 633361 [details] [diff] [review]
part-1-fix-Wall-warnings.patch

Part 1: mozglue/android: fix gcc -Wall warnings
Comment 2 Chris Peterson [:cpeterson] 2012-06-14 19:11:22 PDT
Created attachment 633362 [details] [diff] [review]
part-2-fix-pedantic-warnings.patch

Part 2: mozglue/android: fix gcc -pedantic warnings

gcc -pedantic warns about dlsym() casts because ISO C does not guarantee that sizeof(function pointer) == sizeof(void*), though that would be an unusual machine architecture. To suppress these warnings, this patch casts dlsym()'s return value from void* to uintptr_t to a function pointer.

Note You need to log in before you can comment on or make changes to this bug.