Last Comment Bug 765203 - Support mode "unknown" when parsing cache manifest
: Support mode "unknown" when parsing cache manifest
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Networking: Cache (show other bugs)
: Trunk
: All All
: -- enhancement (vote)
: mozilla16
Assigned To: Honza Bambas (:mayhemer)
:
Mentors:
http://www.whatwg.org/specs/web-apps/...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-15 05:02 PDT by Honza Bambas (:mayhemer)
Modified: 2012-07-14 10:01 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (6.39 KB, patch)
2012-07-12 12:43 PDT, Honza Bambas (:mayhemer)
jduell.mcbugs: review+
honzab.moz: checkin+
Details | Diff | Review

Description Honza Bambas (:mayhemer) 2012-06-15 05:02:00 PDT

    
Comment 1 Honza Bambas (:mayhemer) 2012-07-10 14:59:50 PDT
We have to allow sections other then e.g. NETWORK, EXPLICIT etc simply by ignoring/skipping them.  This is needed for forward compatibility when the spec adds new sections, as has happened recently.  This should be tracked for FX16 as this is very simple and safe to implement and compat important.
Comment 2 Honza Bambas (:mayhemer) 2012-07-12 11:51:31 PDT
Steeling the bug back.  I would like to get this done for Fx16.
Comment 3 Honza Bambas (:mayhemer) 2012-07-12 12:43:20 PDT
Created attachment 641565 [details] [diff] [review]
v1

- const_iterator doesn't support - operator.. quit sad.
- end cannot be equal to begin since there if it would, the method would exit earlier above (there is if (begin == end || *begin == '#') return NS_OK;)
Comment 4 Alex Keybl [:akeybl] 2012-07-13 16:34:47 PDT
(In reply to Honza Bambas (:mayhemer) from comment #1)
> This should be tracked
> for FX16 as this is very simple and safe to implement and compat important.

The only part of that justification that qualifies for tracking is the compatibility importance. Can you give us more context there? Thanks!
Comment 5 Jason Duell [:jduell] (needinfo? me) 2012-07-13 19:53:32 PDT
Comment on attachment 641565 [details] [diff] [review]
v1

Both code + test look good.
Comment 6 Honza Bambas (:mayhemer) 2012-07-14 02:47:26 PDT
(In reply to Alex Keybl [:akeybl] from comment #4)
> The only part of that justification that qualifies for tracking is the
> compatibility importance. Can you give us more context there? Thanks!

In the current-work spec it is marked as ready-for-first-implementation.  I checked with chrome (dev channel) that it supports unknown sections.  There has recently been introduced SETTINGS section, that when encountered by our manifest parser leads to break of the manifest load and thus the whole app doesn't get cached.

I'm going to land this patch now, since it is simple, has a test, and I don't see any reason why we should hold it back.
Comment 8 Ryan VanderMeulen [:RyanVM] 2012-07-14 10:01:55 PDT
https://hg.mozilla.org/mozilla-central/rev/2ff61044edbd

Note You need to log in before you can comment on or make changes to this bug.