java.lang.NoSuchMethodError: java.lang.String.isEmpty at org.mozilla.gecko.BrowserToolbar$2.onCreateContextMenu(BrowserToolbar.java)

VERIFIED FIXED in Firefox 15

Status

()

Firefox for Android
General
--
critical
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Scoobidiver (away), Assigned: wesj)

Tracking

({crash, regression})

15 Branch
Firefox 16
ARM
Android
crash, regression
Points:
---

Firefox Tracking Flags

(firefox15 fixed, firefox16 verified)

Details

(Whiteboard: [native-crash], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
There's one crash in 16.0a1/20120614075912: bp-2ce43818-b5d6-4bb5-94a6-0898e2120615.

The regression window might be:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=964b11fea7f1&tochange=983b91e5aa17

java.lang.NoSuchMethodError: java.lang.String.isEmpty
	at org.mozilla.gecko.BrowserToolbar$2.onCreateContextMenu(BrowserToolbar.java:120)
	at android.view.View.createContextMenu(View.java:4239)
	at com.android.internal.view.menu.ContextMenuBuilder.show(ContextMenuBuilder.java:81)
	at com.android.internal.policy.impl.PhoneWindow$DecorView.showContextMenuForChild(PhoneWindow.java:1914)
	at android.view.ViewGroup.showContextMenuForChild(ViewGroup.java:459)
	at android.view.ViewGroup.showContextMenuForChild(ViewGroup.java:459)
	at android.view.ViewGroup.showContextMenuForChild(ViewGroup.java:459)
	at android.view.ViewGroup.showContextMenuForChild(ViewGroup.java:459)
	at android.view.ViewGroup.showContextMenuForChild(ViewGroup.java:459)
	at android.view.View.showContextMenu(View.java:2461)
	at android.view.View.performLongClick(View.java:2447)
	at android.widget.TextView.performLongClick(TextView.java:7851)
	at android.view.View$CheckForLongPress.run(View.java:8834)
	at android.os.Handler.handleCallback(Handler.java:587)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:123)
	at android.app.ActivityThread.main(ActivityThread.java:4668)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:521)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:878)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:636)
	at dalvik.system.NativeStart.main(Native Method)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NoSuchMethodError%3A+java.lang.String.isEmpty+at+org.mozilla.gecko.BrowserToolbar%242.onCreateContextMenu%28BrowserToolbar.java%29
(Assignee)

Comment 1

5 years ago
Created attachment 633524 [details] [diff] [review]
Patch

Stupid me.
Assignee: nobody → wjohnston
Attachment #633524 - Flags: review?(margaret.leibovic)

Comment 2

5 years ago
Comment on attachment 633524 [details] [diff] [review]
Patch

Sorry I didn't catch that before :(
Attachment #633524 - Flags: review?(margaret.leibovic) → review+
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/7e0403e82067
https://hg.mozilla.org/mozilla-central/rev/7e0403e82067
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 16
Quick fix for this bug. It seems that there aren't any other crashes since 06/15. Closing bug as verified fixed on:

Firefox 16.0a1 (2012-06-19)
Device: Galaxy Nexus
OS: Android 4.0.2
Status: RESOLVED → VERIFIED
status-firefox16: --- → verified
(Reporter)

Comment 6

5 years ago
15.0 Beta is affected.
status-firefox15: --- → affected
Version: Firefox 16 → Firefox 15
(Reporter)

Comment 7

5 years ago
It's #48 top crasher in 15.0b3. Can we land it on Beta?
(Reporter)

Comment 8

5 years ago
Now #19 on 15.0b4.

Comment 9

5 years ago
Comment on attachment 633524 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): n/a
User impact if declined: crash (#19 on 15.0b4)
Testing completed (on m-c, etc.): landed on m-c 6/16
Risk to taking this patch (and alternatives if risky): low-risk change to replace a bad method call with one that actually exists
String or UUID changes made by this patch: n/a
Attachment #633524 - Flags: approval-mozilla-beta?
Attachment #633524 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 10

5 years ago
https://hg.mozilla.org/releases/mozilla-beta/rev/7b5be4d31c68
status-firefox15: affected → fixed
You need to log in before you can comment on or make changes to this bug.