Last Comment Bug 765235 - [New Tab Page] test suite should make use of underlying storages
: [New Tab Page] test suite should make use of underlying storages
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 16
Assigned To: Tim Taubert [:ttaubert]
:
Mentors:
Depends on: 780135
Blocks: 753448
  Show dependency treegraph
 
Reported: 2012-06-15 07:25 PDT by Tim Taubert [:ttaubert]
Modified: 2012-08-03 06:49 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v1 (27.15 KB, patch)
2012-06-15 07:25 PDT, Tim Taubert [:ttaubert]
gavin.sharp: review+
Details | Diff | Splinter Review

Description Tim Taubert [:ttaubert] 2012-06-15 07:25:31 PDT
Created attachment 633513 [details] [diff] [review]
patch v1

The about:newtab test suite should not inject its test data directly into NewTabUtils' objects. We should rather modify the DOMStorage values and add visits to the history service. This way we'll also get test coverage of the components responsible for handling those storages. Also, it's harder to create leaking tests that way.

Those are the changes:

* setPinnedLinks() does now write the value directly to the DOMStorage.
* setLinks() operates asynchronously now and injects its links into places/history.
* I needed to replace about:blank with http://example.com/ because the history service rejects about:blank URIs.
Comment 1 Tim Taubert [:ttaubert] 2012-06-15 15:04:47 PDT
Try is green:

https://tbpl.mozilla.org/?tree=Try&rev=48e9a7c2c739
Comment 2 Tim Taubert [:ttaubert] 2012-07-03 02:58:04 PDT
Anyone, please?
Comment 3 Tim Taubert [:ttaubert] 2012-07-07 03:17:06 PDT
https://hg.mozilla.org/integration/fx-team/rev/eb12d458e0fb
Comment 4 Tim Taubert [:ttaubert] 2012-07-07 06:49:58 PDT
https://hg.mozilla.org/mozilla-central/rev/eb12d458e0fb

Note You need to log in before you can comment on or make changes to this bug.