warning for uninitialized variable and unhandled enum in switch

RESOLVED DUPLICATE of bug 755048

Status

()

Core
Disability Access APIs
RESOLVED DUPLICATE of bug 755048
5 years ago
5 years ago

People

(Reporter: hub, Unassigned)

Tracking

15 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
There are so warning for uninitialized variable and unhandled enum in switch in the a11y code.

Attaching patch
(Reporter)

Comment 1

5 years ago
Created attachment 633774 [details] [diff] [review]
Fix warnings. r=
(Reporter)

Updated

5 years ago
Attachment #633774 - Flags: review?(dbolter)
I think there's a patch for this on another bug (about warnings)
(In reply to david.bolter@gmail.com from comment #2)
> I think there's a patch for this on another bug (about warnings)

I'm pretty sure bug 755048 does, and probably ms2gers patch too, but I haven't read all of that one.
Attachment #633774 - Flags: review?(dbolter)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 755048

Comment 5

5 years ago
(In reply to Trevor Saunders (:tbsaunde) from comment #4)
> 
> *** This bug has been marked as a duplicate of bug 755048 ***

I'd say take this one if we have a patch and active assignee. That's the way to move forward faster.
(In reply to alexander :surkov from comment #5)
> (In reply to Trevor Saunders (:tbsaunde) from comment #4)
> > 
> > *** This bug has been marked as a duplicate of bug 755048 ***
> 
> I'd say take this one if we have a patch and active assignee. That's the way
> to move forward faster.

true, on the other hand it seems a bit unfair :/

Comment 7

5 years ago
right but that bug seems to be endless :)
(Reporter)

Comment 8

5 years ago
Resubmitted for bug 755048. as per comment #5
You need to log in before you can comment on or make changes to this bug.