Last Comment Bug 765588 - Named properties on CSSFontFaceStyleDecl broken
: Named properties on CSSFontFaceStyleDecl broken
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: CSS Object Model (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla17
Assigned To: Boris Zbarsky [:bz] (still a bit busy)
:
:
Mentors:
https://www.w3.org/Bugs/Public/show_b...
Depends on:
Blocks: 753517
  Show dependency treegraph
 
Reported: 2012-06-17 09:30 PDT by :Ms2ger (⌚ UTC+1/+2)
Modified: 2012-08-06 07:43 PDT (History)
3 users (show)
bzbarsky: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Make CSSFontFaceStyleDecl an nsICSSDeclaration. (3.02 KB, patch)
2012-06-27 14:47 PDT, Boris Zbarsky [:bz] (still a bit busy)
dbaron: review+
Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2012-06-17 09:30:14 PDT
See <http://software.hixie.ch/utilities/js/live-dom-viewer/saved/1588>.

We throw 'Exception... "Could not convert JavaScript argument"  nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)"...', because the xpc_qsUnwrapThis to nsICSSDeclaration in nsIDOMCSS2Properties_Get fails.

I guess we'll need to have nsCSSFontFaceStyleDecl implement nsICSSDeclaration as well as nsIDOMCSSDeclaration, and audit all other implementations.
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2012-06-18 08:38:44 PDT
This is not a CSSStyleDeclaration; the actual set of supported properties needs to be different.  So it's not at all clear to me that the named property thing should work at all.
Comment 2 :Ms2ger (⌚ UTC+1/+2) 2012-06-18 08:40:22 PDT
That's not what the spec says... <http://dev.w3.org/csswg/cssom/#cssfontfacerule>
Comment 3 Boris Zbarsky [:bz] (still a bit busy) 2012-06-18 08:50:08 PDT
Well, the spec is totally broken.  What, exactly, should .style.azimuth return on a font-face rule?  What should happen when you set .style.display on such a rule?

Maybe this section of the spec was written before CSS2Properties was merged into CSSStyleDeclaration?  Or maybe like most of CSSOM it's just broken and unmaintained?

Do you want to raise the spec issue, or should I?  ;)
Comment 4 Boris Zbarsky [:bz] (still a bit busy) 2012-06-27 14:47:04 PDT
Created attachment 637268 [details] [diff] [review]
Make CSSFontFaceStyleDecl an nsICSSDeclaration.
Comment 5 Boris Zbarsky [:bz] (still a bit busy) 2012-06-27 14:48:06 PDT
Note that in bug 753517 I plan to disappear these props from here altogether (which will be somewhat different than them throwing).  Hence the lack of a test for them working, though I could certainly add a test for the getter not throwing.
Comment 6 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2012-08-03 16:29:58 PDT
Comment on attachment 637268 [details] [diff] [review]
Make CSSFontFaceStyleDecl an nsICSSDeclaration.

r=dbaron
Comment 7 Boris Zbarsky [:bz] (still a bit busy) 2012-08-05 19:18:42 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/466ee6779566
Comment 8 Ed Morley [:emorley] 2012-08-06 07:43:17 PDT
https://hg.mozilla.org/mozilla-central/rev/466ee6779566

Note You need to log in before you can comment on or make changes to this bug.