The google image preview opened from image search results is very small

RESOLVED INVALID

Status

Tech Evangelism
Mobile
RESOLVED INVALID
6 years ago
4 years ago

People

(Reporter: AdrianT, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Android

Firefox Tracking Flags

(firefox14 affected, firefox15 affected, firefox16 affected, fennec-)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 633957 [details]
screenshot

Nightly/16.0a1 2012-06-17 / Aurora 15.0a1 2012-06-17 / Firefox Native 14.0b7 build 3
Device: HTC Desire
OS: Android 2.2.2

Steps to reproduce:
1. Go to google.com. Change to the classic version.
2. From the menu go to image search.
3. Search for some images. Try "space" for e.g.
4. Tap on any result to open the results page.

Expected results:
The results page is opened and an overlay with the image preview is displayed over the page.

Actual results:
The image preview is very small.
(Reporter)

Comment 1

6 years ago
Created from the original issue Bug 753675 to cover the size of the preview because the positioning has been fixed.
Load this in your browser window:

https://bug765657.bugzilla.mozilla.org/attachment.cgi?id=633957

And then resize your browser window to the size of a mobile device.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
I mean http://www.google.com/imgres?hl=en&biw=1920&bih=895&gbv=2&tbm=isch&tbnid=-_rKnqhtg1obUM:&imgrefurl=http://www.star.ac.za/&docid=jcmJALTMmZkonM&imgurl=http://www.star.ac.za/graphics/n11lmc_noao.jpg&w=640&h=480&ei=-yzfT7z9OKyK6QHo8YS6Cw&zoom=1&iact=hc&vpx=316&vpy=145&dur=90&hovh=194&hovw=259&tx=97&ty=100&sig=109949579808699319488&page=1&tbnh=125&tbnw=164&start=0&ndsp=51&ved=1t:429,r:1,s:0,i:78
(Reporter)

Comment 4

6 years ago
Created attachment 634016 [details]
Firefox_Android Browser_Desktop comparison

Please see the difference in proportion between Firefox Mobile, the Stock Android Browser and Desktop Firefox. The Firefox Mobile preview is visibly smaller in size proportionally to the screen size. I understand being smaller because of a screen but the image preview is smaller then the image displayed in the google search result - why would I open a preview that is smaller then the initial image? In my opinion this is a bug. Reopening.
(Reporter)

Updated

6 years ago
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Updated

6 years ago
tracking-fennec: --- → ?
The size and dimensions of your desktop are still not the same as the mobile version so I'm still convinced that this is not a bug at all.
Martijn - Can you try to make a reduced test case?
Component: General → Evangelism
tracking-fennec: ? → -
When I try to reproduce with the STR specific in comment 0, selecting images from the classic menu takes me to the mobile site. I cannot get to the classic image search site.

In general, I think all bets are off when displaying desktop content on mobile. However, this is an issue with mobile image search as selecting any image that is returned as part of the Google mobile image search kicks me out to the desktop image page. This is quite different than the experience in Chrome.
Blocks: 759981

Updated

5 years ago
Component: Evangelism → Mobile
Product: Firefox for Android → Tech Evangelism
Version: Firefox 16 → unspecified

Comment 8

4 years ago
I'm not sure I get  the bug.
When Going to google with Firefox for Android (23). If we use Image search with space, everything is fine.
If we ask the classic version, indeed everything is small but **that is normal** because classic == desktop.

I'm inclined to close it as INVALID.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.