-moz-transform object inside an -moz-transform iframe not visible until pinch zooming

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: Martijn Wargers (dead), Unassigned)

Tracking

({regression, testcase})

Trunk
ARM
Android
regression, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(fennec-)

Details

(URL)

(Reporter)

Description

6 years ago
The testcase is from bug 678193 (testcase2).

On my Galaxy Nexus, I can't see the green block in the second iframe, until I pinch zoom in a little, then it suddenly appears.
This is a -moz-transform object inside an -moz-transform iframe.

Not sure if this is a regression, but I suspect so.
I can also see the bug in Fennec beta.
I can confirm this is a regression. Both green blocks are visible on Nightly 14.0a1 2012-03-15 (the mapple merge build). I will work on narrowing down the regression window more.

Updated

6 years ago
tracking-fennec: --- → ?
Good build: April 17th 2012
Bad build: April 18th 2012

Possible regression range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c61e7c3a232a&tochange=0c7e2911be75
Keywords: regressionwindow-wanted

Comment 3

6 years ago
(In reply to adrian tamas from comment #2)
> Good build: April 17th 2012
> Bad build: April 18th 2012
> 
> Possible regression range:
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=c61e7c3a232a&tochange=0c7e2911be75

Perhaps a regression from Bug 728983?
I wouldn't have thought so, but maybe.

Maybe Alice can find the regression range? :-)

Comment 5

6 years ago
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #4)
> Maybe Alice can find the regression range? :-)

Sorry, I cannot (because, i do not have a android box).
(Reporter)

Updated

6 years ago
Keywords: regressionwindow-wanted
I'll work on bisecting this.
(In reply to Ali Juma [:ajuma] from comment #3)
> (In reply to adrian tamas from comment #2)
> > Good build: April 17th 2012
> > Bad build: April 18th 2012
> > 
> > Possible regression range:
> > http://hg.mozilla.org/mozilla-central/
> > pushloghtml?fromchange=c61e7c3a232a&tochange=0c7e2911be75
> 
> Perhaps a regression from Bug 728983?

Confirmed 
Good - 2745411f4bb9 - Andrei — Bug 739191
Bad  - 6dbdb799fa6d - Robert O'Callahan — Bug 728983
Blocks: 728983
Removing regressionwindow-wanted since the regression has been identified
Keywords: regressionwindow-wanted
Yes, it seems so - marking as a dependent.
Depends on: 772079
re-test please
Keywords: qawanted
(Reporter)

Comment 12

6 years ago
Seems to be still a problem in today's trunk build on the Galaxy Nexus.
Keywords: qawanted
tracking-fennec: ? → -
Seems to be fixed.
(Reporter)

Comment 14

2 years ago
Yes, marking wfm.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.