Closed Bug 765712 Opened 8 years ago Closed 8 years ago

Crash - java.lang.IllegalArgumentException: Bad limit (capacity 2097152): -1024 @ ScreenshotImage.copyBuffer(ScreenshotLayer.java:137)

Categories

(Firefox for Android :: General, defect, critical)

ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 765463
Tracking Status
firefox16 --- affected

People

(Reporter: aaronmt, Unassigned)

References

()

Details

(4 keywords, Whiteboard: [native-crash])

Crash Data

Attachments

(1 file)

E/GeckoAppShell( 1559): >>> REPORTING UNCAUGHT EXCEPTION FROM THREAD 179 ("GeckoBackgroundThread")
E/GeckoAppShell( 1559): java.lang.IllegalArgumentException: Bad limit (capacity 2097152): -1024
E/GeckoAppShell( 1559): 	at java.nio.Buffer.limitImpl(Buffer.java:312)
E/GeckoAppShell( 1559): 	at java.nio.Buffer.limit(Buffer.java:303)
E/GeckoAppShell( 1559): 	at org.mozilla.gecko.gfx.ScreenshotLayer$ScreenshotImage.copyBuffer(ScreenshotLayer.java:137)
E/GeckoAppShell( 1559): 	at org.mozilla.gecko.gfx.ScreenshotLayer$ScreenshotImage.setBitmap(ScreenshotLayer.java:144)
E/GeckoAppShell( 1559): 	at org.mozilla.gecko.gfx.ScreenshotLayer.setBitmap(ScreenshotLayer.java:53)
E/GeckoAppShell( 1559): 	at org.mozilla.gecko.gfx.LayerRenderer.setCheckerboardBitmap(LayerRenderer.java:138)
E/GeckoAppShell( 1559): 	at org.mozilla.gecko.ScreenshotHandler$1.run(GeckoAppShell.java:2338)
E/GeckoAppShell( 1559): 	at android.os.Handler.handleCallback(Handler.java:605)
E/GeckoAppShell( 1559): 	at android.os.Handler.dispatchMessage(Handler.java:92)
E/GeckoAppShell( 1559): 	at android.os.Looper.loop(Looper.java:137)
E/GeckoAppShell( 1559): 	at org.mozilla.gecko.GeckoBackgroundThread.run(GeckoBackgroundThread.java:31)
I/GeckoScreenshot( 1559): rect: 165.250000, 102.733337, 103.733337, 180.500000
D/Zygote  (  119): Process 1559 terminated by signal (11)
I/ActivityManager(  193): Process org.mozilla.fennec (pid 1559) has died.
I/WindowManager(  193): WIN DEATH: Window{41b6e2d8 SurfaceView paused=false}
Crash Signature: [@ java.lang.IllegalArgumentException: Bad limit (capacity 2097152): -1024 at java.nio.Buffer.limitImpl(Buffer.java) ]
bp-4d826388-3ca4-4a2a-863e-4106f2120618
Crash Signature: [@ java.lang.IllegalArgumentException: Bad limit (capacity 2097152): -1024 at java.nio.Buffer.limitImpl(Buffer.java) ] → [@ java.lang.IllegalArgumentException: Bad limit (capacity 2097152): -1024 at java.nio.Buffer.limitImpl(Buffer.java)]
See Also: → 765463
Blocks: 755070
STR:

1. www.ups.com, pick your country
2. Tap into the top left package tracker, the virtual-keyboard is invoked

Leave device idle; track dozens of GeckoScreenshots in log-cat. Fennec eventually crashes
Keywords: reproducible
Attachment #634015 - Attachment description: Nightly (06/13) - Raw log → Nightly (06/18) - Raw log
Keywords: regression
It's a dupe of bug 765463 that contains signatures matching java.lang.IllegalArgumentException: Bad position (limit 2097152): <n> at java.nio.Buffer.limitImpl(Buffer.java).
Keywords: topcrash
Scoobidiver, can we just close this bug as a dupe of bug 765463? These bugs have different signatures, but effectively the same stack trace.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 765463
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.