Last Comment Bug 765733 - Don't emit singleton array initializers for empty arrays
: Don't emit singleton array initializers for empty arrays
Status: RESOLVED FIXED
[js:t]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla16
Assigned To: Jan de Mooij [:jandem] (PTO until July 31)
:
Mentors:
Depends on:
Blocks: IonSpeed
  Show dependency treegraph
 
Reported: 2012-06-18 07:44 PDT by Jan de Mooij [:jandem] (PTO until July 31)
Modified: 2012-06-19 01:21 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.50 KB, patch)
2012-06-18 07:44 PDT, Jan de Mooij [:jandem] (PTO until July 31)
bhackett1024: review+
Details | Diff | Splinter Review

Description Jan de Mooij [:jandem] (PTO until July 31) 2012-06-18 07:44:36 PDT
Created attachment 634035 [details] [diff] [review]
Patch

Kraken crypto-aes/crypto-ccm have a bunch of arrays like [[], [], [], []]. The inner/empty arrays have "unknown properties" because fixArrayType cannot easily determine their type.

This is at least a 10% Kraken crypto-aes/crypto-ccm IonMonkey win since it avoids some GETELEM/SETELEM IC's. JM+TI win is smaller.
Comment 1 Jan de Mooij [:jandem] (PTO until July 31) 2012-06-18 08:15:25 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/e7d593a7e561
Comment 2 Ed Morley [:emorley] 2012-06-19 01:21:01 PDT
https://hg.mozilla.org/mozilla-central/rev/e7d593a7e561

Note You need to log in before you can comment on or make changes to this bug.