Improve rendering of downscaled images

RESOLVED DUPLICATE of bug 486918

Status

()

defect
RESOLVED DUPLICATE of bug 486918
7 years ago
7 years ago

People

(Reporter: nick, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120614114901

Steps to reproduce:

Rendering of downscaled images is pretty awful compared to WebKit.

I've attached an image that shows this by comparing Firefox to Chrome. The original is 580x440, downscaled to 116x88 and 58x44.

Bug 98971 might be related, it's marked as fixed but doesn't seem to have addressed this problem.


Actual results:

Image quality is noticeably bad after downscaling through width/height attributes or CSS (see attachment)


Expected results:

Rendering of downscaled images should be identical to WebKit so that there is no perceived quality loss (see attachment)

Comment 1

7 years ago
Bug 486918?

Comment 2

7 years ago
Yes.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 486918
You need to log in before you can comment on or make changes to this bug.