huge context menu in ftp of file listing when no content in focus

VERIFIED FIXED in mozilla0.9.1

Status

SeaMonkey
UI Design
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: Bradley Baetz)

Tracking

Trunk
mozilla0.9.1

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
this is reminiscent of bug 74019 --but i'm not sure if it's the same exact
thing, hence this bug. :)

1. go to an ftp site or directory view listing --best to go to one where the
listing does *not* take up the entire viewer region [ie, no scrolling needed].
2. make sure that no file or folder is selected or highlighted.
3. bring up context menu

result: context menu with extra helpings! ;) will attach screenshot soon.
(Reporter)

Comment 1

17 years ago
Created attachment 31367 [details]
context menu w/too many items
(Reporter)

Updated

17 years ago
Keywords: nsbeta1, nsCatFood
(Assignee)

Comment 2

17 years ago
I don't see this. Are you getting js errors to the console when this happens? If
so, then this is a symptom of bug 74539 - when the JS is invalid, all the
possible entries in the context menu show for some reason. (That may be the
reason for bug 74019)

If you can reliably reproduce this, please add comments to 74539 :)
(Reporter)

Comment 3

17 years ago
yep, i can reliably repro this bug --and i do get js errors:

JavaScript error: 
chrome://communicator/content/nsContextMenu.js line 277: root.getAttribute is
not a function

JavaScript error: 
chrome://cookie/content/cookieContextOverlay.xul line 94: contextMenu has no
properties

JavaScript error: 
 line 0: contextMenu has no properties

JavaScript error: 
chrome://communicator/content/directory/directory.js line 228:
tree.database.RemoveDatasource is not a function

will also add to bug 74539 --however, let me know if i should dup this one in
favor or 74539. thx!
(Assignee)

Comment 4

17 years ago
*** Bug 77022 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

17 years ago
I'll steal this from blake, and attach a patch.
Assignee: blakeross → bbaetz
Target Milestone: --- → mozilla0.9.1
(Assignee)

Comment 6

17 years ago
Created attachment 31726 [details] [diff] [review]
patch
(Assignee)

Comment 7

17 years ago
URL is no longer an attribute on the URL element. So the loop ends up in the
XULDocument, which doesn't have a getAttribute method, and so we get a js error,
which causes the context menu to include all items. This is possibly related to
some of my directory viewer changes, but may not be.

blake, can I get an r=?
Status: NEW → ASSIGNED

Comment 8

17 years ago
r=morse
sr=ben since it's just code movement, but you know this is going to break if 
the directory viewer changes to outliner... 
(Assignee)

Comment 10

17 years ago
Yeah - this entire block (which is only entered if we are an instanceof a
directory viewer) will. There are a couple of other places as well in the code
that assume the directory viewer is a tree IIRC.
(Assignee)

Comment 11

17 years ago
Fix checked in.

Note to QA - to verify this, you'll have to turn off the html ftp directory
listing (which is now on by default), or use a file:/// url.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

17 years ago
vrfy fixed using opt comm bits:

winnt - 2001.05.17.10
linux and mac - 2001.05.17.08
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.