Right-clicking on a text-selected property value and choosing "Copy property value" doesn't update the clipboard

RESOLVED DUPLICATE of bug 788458

Status

()

Firefox
Developer Tools: Inspector
RESOLVED DUPLICATE of bug 788458
6 years ago
6 years ago

People

(Reporter: jaws, Assigned: dcamp)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

STR:
1) Left click on a property value in the rule view.
2) Right click on the selection
3) Choose "Copy property value"

Expected:
Selected value will now be in the clipboard. If the selection was adjusted, only the selected part should be in the clipboard.

Actual:
The clipboard is never updated, so whatever was previously in the clipboard is still there.
(Assignee)

Comment 1

6 years ago
Created attachment 634250 [details] [diff] [review]
v1

This fixes the problem described, and also fixes hitting ctrl-c while an editor is up to work as expected.
Attachment #634250 - Flags: review?(paul)
Wow, that was fast. And tests too! :) dcamp++
(Assignee)

Updated

6 years ago
Attachment #634250 - Flags: review?(paul)
What's the status on this bug? I still see it in the latest Nightly.

Updated

6 years ago
Blocks: 794254
Bug 788458 fixes this issue (amongst others), closing duplicates.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 788458
You need to log in before you can comment on or make changes to this bug.